Support » Fixing WordPress » include errors with nighly 2004-08-10

  • in wp-setting.php the following lines cause include errors in the latest nightly:
    errors:

    Warning: main(d:\apache group\apache\htdocs\wordpress/wp-content/plugins/): failed to open stream: Permission denied in d:\apache group\apache\htdocs\wordpress\wp-settings.php on line 87
    Warning: main(): Failed opening 'd:\apache group\apache\htdocs\wordpress/wp-content/plugins/' for inclusion (include_path='d:\php\pear') in d:\apache group\apache\htdocs\wordpress\wp-settings.php on line 87

    current code lines 83-87:

    if ( get_settings('active_plugins') ) {
    $current_plugins = get_settings('active_plugins');
    foreach ($current_plugins as $plugin) {
    if (file_exists(ABSPATH . 'wp-content/plugins/' . $plugin))
    include(ABSPATH . 'wp-content/plugins/' . $plugin);

    vs. nightly 08-04 where it works on a WAMP System (localhost) with Pear installed.

    if (!strstr($_SERVER['PHP_SELF'], 'wp-admin/plugins.php') && get_settings('active_plugins')) {
    $current_plugins = explode("\n", (get_settings('active_plugins')));
    foreach ($current_plugins as $plugin) {
    if (file_exists(ABSPATH . 'wp-content/plugins/' . $plugin))
    include(ABSPATH . 'wp-content/plugins/' . $plugin);

    HTH
    ai

Viewing 14 replies - 1 through 14 (of 14 total)
  • the same happens to me

    you can replace those line with the ones from the previous nightly and it will work again.
    cheers
    ai.

    i simply replaced those lines with the lines from the previous nightly. the plugins are still listed, though I did not test them all.
    err, the problem is now and not in the future 🙂
    the faulty code exists and so does the problem it has, which of course might not concern you and certainly not the average user unless you are testing nightlies.
    cheers
    ai

    I lost my plugins – had to also replace plugins.php with the older file and reactivate them all.

    You all run upgrade.php after you upgrade to each nightly, right?

    I did a fresh install on my local server, and it returned the same errors.

    Yep, ran upgrade.php twice.

    yep always do run upgrade.php
    maybe it’s due to the mixing of forward and backward slashes in the plugin path string?
    I only have the default PEAR modules installed that come with the go-pear.bat package in apache I guess that is sufficient, at least was until now?

    Try the wp-settings.php file from the new build.

    what new build?
    08-10-2004 is the latest that shows on the nightly directory.

    Invalid argument supplied for foreach() line 87 is because there’s no test that the plugins array is empty prior to the foreach loop use of it.
    -d

    Well, how is everybody else doing, did allusion’s fix work for everybody?
    I now have one plugin that stopped functioning just after the update and am trying to track down why it would return a blank page upon activation. This brings me to a suggestion for the devs – anyway to batch activate/deactivate the plugins? This would certainly help in trying to track down potential plugin conflicts, etc.

    Welll.. i’m one of those who happened to use a ‘broken’ 08-10. However, the updated 08-10 fixed things all up….
    But would really appreciate some way to activate all my old plugins at one go…. I had tons of plugins… and had to go through them one by one.
    All my plugins work though… except in my admin screen….. my blog name is way too long… so it overflows and looks real ugly.

    I had the exact same trouble with the Aug 10 and 17 weeklies where line 87 in wp-setting.php would throw errors. I still had it in Aug 24. De-installed all plugins, still the same problem.
    My problems _did_ go away after following Allusions advice to run the upgrade script (*cough* duh… should have thought about that myself *cough*). I’m going to re-install the plugins and see if everything is still hunky-dory.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.