Support » Plugin: Loco Translate » Inadvertently removed source text – Can’t translate

  • Resolved steve49589

    (@steve49589)


    Howdy,
    So I messed up and somehow deleted the source text when I was “translating” a WooCommerce statement. There are two columns, one for Source Text and the other for Translation. The Source Text content is blank, but the Translation is there.

    Scroll down and there IS the original text in the Source Text box and for the English Translation section, I have what I want the sentence to say. But it is not translating on the front end.

    How can I fix this without deleting the translation and starting over?

    Screenshot – https://pasteboard.co/J85ujQc.jpg

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Tim W

    (@timwhitlock)

    You’ve not deleted anything, but what it looks like you’ve done is edit the woocommerce.pot (template) file, placing your translation in what should be the context field.

    The first thing to do is to reverse that mistake. Download the official woocommerce.pot file and place it in i18n/languages. (Related)

    How can I fix this without deleting the translation and starting over?

    Syncing your en_US file to the correct POT file will start you back on track, but that one translation will be deleted. Only translations whose source text differs in the POT file will be removed. Anything still valid will be safe.

    Note that the file is not saved when you click Sync. Only when you click Save. So try it first and see what has changed.

    If you can’t tolerate losing any translations at all, then you will have to manually edit the PO file or use command line merge tools. I don’t recommend you do this.

    Thread Starter steve49589

    (@steve49589)

    Thank you. I was able to stumble through replacing the file without loosing any translations. But I still could not translate the string.

    Turns out the string I’m trying to change has a history.

    For a single language site, this string…

    Your personal data will be used to process your order, support your experience throughout this website, and for other purposes described in our privacy policy.

    Is edited under WooCommerce > Settings > Accounts & Privacy.

    Thanks again.

    • This reply was modified 1 year, 8 months ago by steve49589.
    Plugin Author Tim W

    (@timwhitlock)

    Thanks for making the effort to look into the “customizable string” problem. I get dozens of emails a week about this kind of thing. Nothing Loco Translate can do about it unfortunately.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Inadvertently removed source text – Can’t translate’ is closed to new replies.