Support » Plugin: UpdraftPlus WordPress Backup Plugin » Inactive registered OAuth URIs for your project(s) will be removed…

  • Resolved Toengel

    (@toengel)


    Hi,

    I just got an email from Google Developers:

    “Inactive registered OAuth URIs for your project(s) will be removed from Google Developer Console by July 12, 2021, for non-compliance with URI validation rules”

    “We are writing to let you know that you have inactive OAuth redirect URIs and JavaScript origins in your Google Cloud project that are not in compliance with Google’s OAuth URI validation rules.”

    “The following Google Cloud project(s), which has/have registered OAuth redirect URIs and JavaScript origins without usage for over 90 days, and which will be removed by July 12, 2021: Project ID: wp-updraftplus-1363

    What can I do?

    Toengel@Alex

Viewing 11 replies - 1 through 11 (of 11 total)
  • Theo

    (@theojones)

    I am also having this issue. Thanks.

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    I have asked one of our developers to check on this.
    We will get back to you soon.

    Best Wishes,
    Bryle

    jb317

    (@jb317)

    Same here. Following for updates.

    girlswithguns

    (@girlswithguns)

    I also got the email. Following for updates

    Plugin Contributor bcrodua

    (@bcrodua)

    Hi,

    Google will now be removing any inactive OAuth redirect URIs from Google Projects.

    In this case, the redirect URI is part of the Oauth Google app used to connect UpdraftPlus to your Google Drive or Google Cloud.

    However, a few years ago, UpdraftPlus switched the method used to authenticate with Google. The old method required each user to create their own Google App, while the new method uses a global app.

    As such, your UpdraftPlus installation most likely uses the new method to authenticate. In this case, the notice from Google is simply to inform you that they will be removing the old, now-unused credentials.

    If your installation still uses the old method (i.e. your Google Drive settings include a Google app id), then those active credentials should not be removed.

    If you have any further questions regarding the Google Drive remote storage, please don’t hesitate to get in touch.

    Thanks,
    Bryle

    dariusirani

    (@dariusirani)

    Thanks! I got the same e-mail.

    cs1337

    (@cs1337)

    Dear @bcrodua,
    I am unsure whether we really do not have to take any action here. I also received this note for several WordPress installations with Updraft. In all cases, the email from Google specifically references the current credentials (especially Google Drive Client ID and redirect URI) listed in my Updraft settings, so I doubt that these are old settings. How can I determine if my site is using the old or new method? How can I switch to the new method, in case google is going through with its announcement to automatically disable old credentials in July?
    Kind regards,
    Chris

    Plugin Author David Anderson

    (@davidanderson)

    Hi Chris,

    If you’re getting this message in relation to Google *Drive* (not Cloud, as per the original poster), then that means you’re using your own Google Drive custom app. Most likely that means you’ve been using it since a time that pre-dates UpdraftPlus having its own approved app. You should just go to the UD settings page on each site, remove custom app settings, and follow the link in the Google Drive settings to re-authenticate using our official app, and then you can safely ignore anything from Google about the custom app.

    We don’t yet have an official Google Cloud app, which is why things are different there. We made an application some time ago which we are now reviving in order to try to resolve the Cloud issue for users.

    David

    cs1337

    (@cs1337)

    @davidanderson Thank you very much for the clarification and help. I had indeed mistaken Google Drive and Google Cloud. I have now re-authenticated with Google Drive as per your suggestion and now I appear to be using the official Updraftplus Google App (i.e. no personal Google Drive Client ID listed anymore under settings). Thank you for resolving my issues and concerns!

    Thank you for the details, but they have me confused. Looking at the settings page, I see the following:
    You must add the following as the authorised redirect URI (under “More Options”) when asked: https://www…
    which I assume remains unchanged?

    There are then following fill-ins:
    Google Drive Client ID
    Google Drive Client Secret
    Google Drive Folder
    which I assume also remain unchanged?

    In the next item, Authenticate, I see, “Follow this link to remove these settings for Google Drive.”
    Is this the correct link to follow to remove the required setting?

    And then, after saving that change, follow the next link, “After you have saved your settings (by clicking ‘Save Changes’ below), then come back here once and follow this link to complete authentication with Google Drive.”

    The remaining options are self explanatory.

    Thanks for the thread and support. Those of you who are confused, if you see fill in fields under AUTHENTICATE w GOOGLE you likely have the old custom app as I did. First field was a long string of characters and there as also a “secret” field. I just deactivated the authentication and redid. Now it’s activated properly without these fields showing. Warm regards, Kristi

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.