WordPress.org

Support

Support » How-To and Troubleshooting » Inability to “Write Page”

Inability to “Write Page”

  • I have been trying to create pages, both with the templates that come with themes, as well as by using the default template/not changing the template setting. No matter what I do, I get no error, the post/page is saved in the database, I can edit the page, but I can never view it. I always get:

    The requested URL /poop/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I have taken the permissions to the permissive max, have tried pre-creating the files/directories, have worked with the extremely nice creator of the themes I am using, Theron, but to no avail.
    I am updating nightly from CVS. I just don’t understand what WP is trying to do when a page is created – I understand that it is being entered as a “non-post post”, but why is a directory being created/linked/??

    If anyone else is having this problem, or has a bit of advice or a link to a previous mention in the support forums (I did search first, honest), I would be grateful for it.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Are you using a beta version?

    Yessir, I guess that I am… I check out from CVS (every)night(that I remember)ly.

    The same thing is happening for me. Pages are created and saved but do not show up when trying to view. I am using 01-15-2005.

    If you can create the page ok but can’t view it then you may not have set the “create a virtual site structure” in the admin panel under options/permalinks properly, or the permalink information did not get written to your .htaccess file

    Set the structure to /%year%/%monthnum%/%day%/%postname%/ and have had no trouble with any of my “posts'” permalinks. Would there have been trouble with both if a mistake in .htaccess were the case?

    Kristin,

    Try adding this to your .htaccess file:

    RewriteRule ^about/?$ /index.php?pagename=about [QSA,L]

    If that fails, you could always just reference the page like so:

    index.php?pagename=about

    Ah…
    After I setup my .htaccess the first time I chmod’d back to read only before trying the “create page” feature. Works like a charm now.

    Hey! Theron, your idea worked, and then making the .htaccess writable again worked too! I guess that the ability to make pages hinges on it being writable. Perhaps a big red label (Warning, Lark’s Vomit?) for those of us (read: me) who can’t put 2 and 2 together. 🙂 Thanks everyone!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Inability to “Write Page”’ is closed to new replies.
Skip to toolbar