Support » Plugin: Antispam Bee » Inability to Comment

  • Resolved Choclette

    (@choclette)


    When I updated the plugin to version to 2.10.0 last week, people were no longer able to comment. After typing in their comment, they were getting an error message as follows “error, please type your comment text”.
    Weirdly, if they tried to comment on the same post 24 hours later, it mostly seemed to work.

    I tried it out to and it was the same for me.

    Obviously I can’t operate like that, so I rolled back to the previous version, 2.9.4 and comments are now working fine again.

    Is this something you’re aware of and will it be addressed in the next update? I don’t really want to stay on an out-of-date version forever, but I can’t update either.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @choclette

    I am on vacation right now. So just a quick reply. Is there any chance you are using a caching plugin? After 24 Hours the Cache is generated again, that could be the reason why it works again. Maybe you just need to purge the cache?

    I will Check more deeply in the Next days!

    All the best
    Torsten

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    If this does not work out. Can you please try to enable „Comment form used outside of posts“?

    This changes the filter usage back to output buffering from 2.9. This way you can stay up to date and hopefully fix the problem.

    All the best
    Torsten

    Plugin Contributor Florian Brinkmann

    (@florianbrinkmann)

    Hi @choclette,

    could you check if the Antispam Bee option »Check complete site markup for comment forms« is active? You find the options under »Settings« › »Antispam Bee«.

    Thanks,
    Florian

    Thread Starter Choclette

    (@choclette)

    Hi Florian and Torsten

    Sorry for not getting back to you before now. As I’m on version 2.9.4 everything’s working fine so I forgot about it. But I obviously can’t stay on an outdated plugin for ever.

    Florian – This doesn’t appear as an option. Is this something you introduced in the 2.10.0 update?

    Torsten, I’m loathe to go back 2.10.0 unless I know it’s going to work. If it was a caching problem, why does that not affect 2.9.4? And if I update should I try Florian’s suggestion first or yours?

    Regards
    Choclette

    Plugin Contributor Florian Brinkmann

    (@florianbrinkmann)

    Hi Choclette,

    oh, yes, sorry, that is a new option in 2.10.0 and in some way replaces the option mentioned by Torsten. But, if everything works while updating Antispam Bee to 2.10.0, that option should be active by default for existing Antispam Bee installations (and then uses the same mechanism like in 2.9.4).

    Could you create a copy of your website and update Antispam Bee there so that we can see the error in action?

    Best,
    Florian

    Thread Starter Choclette

    (@choclette)

    Hi Florian

    I can’t take a copy of my website, but I’m willing to give the update another go. So if I update to 2.10.0 – again, I then need to “check complete site markup for comment forms” in settings? Is that correct?

    Regards

    Choclette

    Plugin Contributor Florian Brinkmann

    (@florianbrinkmann)

    Hi Choclette,

    yes, but that option should be active by default after an update. If that migration does not work and the option is disabled, that could be the reason for the issue. But that is only a guess.

    Best,
    Florian

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @choclette,

    any news on that matter? Has it worked this time or didn’t you tried again yet?

    All the best,
    Torsten

    Thread Starter Choclette

    (@choclette)

    Hi Torsten

    I haven’t tried again, because there doesn’t seem to be an obvious answer. And it’s not easy to test as I need to know someone has tried and failed to comment. But I might try again today and see if that box is checked. It’s just a big hassle and extra load on my network resources as I’ll have to backup first etc. I’ll let you know.

    Thread Starter Choclette

    (@choclette)

    I’ve just updated the plugin again, but as I suspected, the same error message is coming up when I try to comment. Nothing has changed, so I’m not sure why that would have changed either.

    I checked to make sure the “Check complete site markup for comment forms” was active and it is.

    Thread Starter Choclette

    (@choclette)

    Following on from my last comment. I’ve just purged caches everywhere and the comment I just attempted worked. So I’ll stick with this version for a while and see what happens.

    I’m just concerned that I will miss comments from readers who won’t come back and try again or even tell me there is a problem.

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @choclette

    I’m just concerned that I will miss comments from readers who won’t come back and try again or even tell me there is a problem.

    I’ve commented on “Teriyaki Rice Bowl Recipe with Tofu & Brussels Sprouts” and the comment is awaiting moderation. No error message.

    I think this is just a caching issue. Purging the cache seems to have fixed it. If it breaks again please report again we will have a closer look!

    All the best
    Torsten

    Thread Starter Choclette

    (@choclette)

    Thanks Torsten and thanks for your comment too. I got it and as far as I’m aware haven’t had any comment issues since purging.

    I will let you know if it all goes pear shaped again.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Inability to Comment’ is closed to new replies.