WordPress.org

Support

Support » Plugins and Hacks » [Resolved] In version 0.9.4 watermark does not overlap the image on my site

[Resolved] In version 0.9.4 watermark does not overlap the image on my site

  • I debug this error and see:
    In wm_functions.php->mm_applyWatermark() have

    $mm_applyWatermarkExecute == false

    because my server not support function exif_imagetype and if picture have addres examle

    $checkfile = /home/server/site.com/www/wp-content/uploads/skrin.jpg

    then MM_CheckFile_WM function not show correct extension of picture file and return false.

    This bug I fix follows and offer to fix this in your plugin:
    in wm_functions.php 4 and 5 rows


    list($tmpaa, $tmpab, $tmpac)=split(“\.”,$checkfile,3);
    if((empty($tmpab)) || ($tmpac!=””)) return false;

    replaced on

    $path_info = pathinfo($checkfile);
    $tmpab = $path_info[‘extension’];

    P.S. I apologize for my English

    http://wordpress.org/extend/plugins/marekkis-watermark/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author marekki

    @marekki

    Hi Dayver.

    thank you for your hint. I’ll use your solution in the next version of my plugin. The core functions of my plugin are very old but works. So hints like yours are very good reason to update them and to use the new build-in wordpress or php functions.

    I close this thread and hope for more hints like this one.

    Best wishes to Kiev.
    Marekki.

    Thank you very much

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] In version 0.9.4 watermark does not overlap the image on my site’ is closed to new replies.