Support » Plugin: Easy FancyBox » In theme Enigma Premium Advance not working

  • Resolved PeterBe_SK

    (@peterbe_sk)


    Hello RavanH and plugin users,

    I tried switch theme from Enigma Pro to Enigma Premium Advance 2.5.8 and Easy Fancybox not working. In the Enigma Pro Ver: 2.4 plugin working correctly.

    After click to picture, link opens only this picture in browser tab. Must click button back in browser to show post again.

    Please, do you know how resolve it? Easy Fancybox is very nice plugin.
    Thank you very much.
    Peter

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author RavanH

    (@ravanh)

    Hi Peter, it sounds like Enigma Premium Advance introduces a conflict but I cannot tell you what it is or how to resolve it. Can you share a link? I might be able to tell you a little bit more…

    In any case, the best option would be to get support from the theme developers. They’ll surely be able to spot the issue faster 🙂

    PeterBe_SK

    (@peterbe_sk)

    Hi RavanH,
    Thank you for reply. I can’t public share link to page in development environment. 🙁 If it is possible send private message I send link to you.
    I will try ask in weblizar theme forum.
    Thank you very much.
    Peter

    Plugin Author RavanH

    (@ravanh)

    Or you can open the developer tools in your browser (usually with F12) and watch the Console log tab when reloading the page. It might reveal some critical script errors that will usually block the light box script (because it loads later than everything else)…

    PeterBe_SK

    (@peterbe_sk)

    Thank you for reply,
    This is from Chrome console (red error)

    jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
    jquery.fancybox-1.3.8.min.js:1 Uncaught TypeError: a.fancybox.init is not a function
    at HTMLDocument.<anonymous> (jquery.fancybox-1.3.8.min.js:1)
    at i (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at Function.ready (jquery.js:2)
    at HTMLDocument.K (jquery.js:2)

    After I switch theme back to Enigma Pro 2.4 it is without this error.
    Thank you.

    Plugin Author RavanH

    (@ravanh)

    That is indeed a blocking error. If you search through the source code (normally with Ctrl+U) can you see how many times there is a jquery.js or jquery.min.js referenced in there?

    PeterBe_SK

    (@peterbe_sk)

    In both themes everything in code around jquery is same except this row
    <script type=’text/javascript’ src=’https://yyyzzz/wp-content/themes/enigma-premium-advance/js/jquery.countTo.js?ver=4.9.1′></script&gt;
    It’s almost at the end of code. In theme with working plugin this row is not included.

    In theme with not working plugin “a href tag” with picture missing this …class=”fancybox image” rel=”gallery”…

    Reference to jquery.min.js is missing in both themes code.

    I will try prepare another demo environment for sharing here.

    Thank you.

    PeterBe_SK

    (@peterbe_sk)

    RavanH, I prepared fresh WP demo environment with Enigma Advance theme and Easy Fancybox. This is demo post https://tinyurl.com/y8zce5rj with 2 pictures.
    Thank you very much.
    Peter

    Plugin Author RavanH

    (@ravanh)

    Thanks for that demo site! I have included the same script file on demo.status301.net but there it does not cause an error. Only difference: the countTo script is included before and not after the fancyBox script…

    Will have to test further.

    Plugin Author RavanH

    (@ravanh)

    By the way, the theme seems to include photobox.js already so you may want to try to use that one instead of fancybox. A very crude way to do this could be adding this to a footer HTML widget:

    
    <script type="text/javascript">
    jQuery('.hentry').photobox('a[href*=".jpg"]:not(.nolightbox),a[href*=".png"]:not(.nolightbox)');
    </script>
    

    Although untested, this should (as I understand the Photobox instructions) enable that light box script on all jpg and png links (except those with class “nolightbox” so you have a way to disable for certain links) inside a post on your site. Note that this might conflict with any galleries that already have enabled Photobox…

    PeterBe_SK

    (@peterbe_sk)

    RavanH,
    I tried your code in footer html widget and it working, but not in your Easy FancyBox – it is deactivated at this moment in demo site :(.
    Will wait for next version of theme, because your plugin is very nice. Included PhotoBox or SwipeBox is primary for portfolio options.
    Thank you very much.

    Plugin Author RavanH

    (@ravanh)

    Yes, the idea was to use the theme included light box for everything instead of loading two different light boxes. You can remove Easy FancyBox now, your site will be faster… 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘In theme Enigma Premium Advance not working’ is closed to new replies.