Support » Fixing WordPress » In the process of changing directory – No site!

  • Resolved Milsie

    (@milsie)


    I have been following the instructions here: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    ..to change my site location to the domain name I bought through the same hosting package. The domain name is http://www.touchtitanium.com which is at this minute displaying without the theme applied.

    I have tried changing the index.php file in the root back to the original and have deleted the .htaccess file I created manually to update the permalinks in there. (wouldn’t update automatically even though permissions were set fine).

    So now I am staring at a non-functional site with no style and no access to the admin panel. When I type in the old admin address it redirects quickly to touchtitanium.com/admin which says ‘Internal Server Error’.

    Any ideas guys?

Viewing 15 replies - 1 through 15 (of 45 total)
  • esmi

    (@esmi)

    Forum Moderator

    I saw it and I tried method 1 and 3. Neither worked.

    I am seeing a white browser window on method 3 (the Relocate Method)

    I don’t get it. I’ve changed everything back to how it was before. The only part that’s wrong was set in the admin panel under the General settings and they were the Site addresses.

    I need to get back in to the admin panel in order to change the Site links back to their original longer names. That should put everything back to normal. Can you tell me which .php file holds this information so I can edit manually?

    Really appreciate your help by the way. I’m stressing a bit. 😀

    esmi

    (@esmi)

    Forum Moderator

    I need to get back in to the admin panel in order to change the Site links back to their original longer names

    No – you do not! Read that page carefully.

    esmi, I am getting some Warning and Fatal error messages now that I have restored the .htaccess file to it’s previus state. I think it is conflicting with the database. Something about ‘line 17’. Can I contact you directly by email? No worries if not.

    Looking at this point now: Changing the URL directly in the database

    I am looking directly at the database, showing all and doing a search for ‘siteurl’. It’s not there.

    This is very confusing. I’m going to try posting somewhere else. I’m not good with code, which is why I enjoy WordPress.

    Thanks for your time.

    esmi

    (@esmi)

    Forum Moderator

    It’s not there.

    Yes – it is. Try looking in the wp_options table.

    No – it’s not. I was looking and am looking again on the wp-options table. Showing up to 800 entries and 5 containing the word ‘url’.

    The site is obviously still there, but it doesn’t know where any of the files are so non of the images are linking up and the theme is not being applied and there is no admin panel access.

    So supposing there is no ‘siteurl’ entry, what then?

    If this is the exact location of my config file, shouldn’t I be seeing something on this page?

    http://s414604449.websitehome.co.uk/touchtitanium/wp-config.php

    Just raised my search to 1000 rows on the database and the ‘siteurl’ entry has appeared. Yes, you told me so 😛

    I don’t really want to tamper with this but I guess if it’s the only option…

    I’ve done what it said and changed both entries to:

    http://s414604449.websitehome.co.uk/touchtitanium/blog

    Does that look correct, esmi?

    Didn’t work so I’ve changed it to:

    http://touchtitanium.com/touchtitanium

    .. this was what I originally had in both General settings.

    Still doesn’t work.

    hold on, that’s wrong.

    http://s414604449.websitehome.co.uk/touchtitanium/

    Now I got a page for a second, an error 404! But no admin panel…

    Do the new addresses have to have an http:// at the front?

    Surely my .htaccess folder is now out of date…

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘In the process of changing directory – No site!’ is closed to new replies.