Support » Plugin: RPS Include Content » In results page need to show parent not included childrens

  • Resolved masterbip


    Hi there. This plugin is awesome. Thanks for that.

    Well, i got 3 parent pages that includes with the plugin 5 different child pages each.
    In my site I show the parent page and all works awesome.

    But if I make a search, the results shows me the child pages, not the parent one, and it mess the design and functionality of the site.

    I need to know how can I search but in results show the parent of the children page that get the content, and not the children itself.

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author redpixelstudios


    Glad you are finding RPS Include Content to be useful. There might be a solution for you using the following approach.

    Set all of the pages that should not show in search (the included content) to “private”. Then make sure that the Include Content Setting labeled “Show private included content without restriction” is checked. Let us know if that works for you or if you have additional questions.

    Thanks for that, but didn’t worked as expected.
    I search something and it still appears in results page as
    “PRIVATE: The title of the included page”

    Do i have to do something with my search function?

    Thanks a lot for your answer.

    Plugin Author redpixelstudios


    It is possible the private posts are showing in your search results because you are logged in as a user with the capabilities required to see them. Try logging out and executing your search again.

    Let us know if that doesn’t address the issue and we can point you in the right direction to information about how to modify your search query.

    Plugin Author redpixelstudios


    Hopefully our explanation of what might be happening helped you. Feel free to reopen this topic if it warrants further discussion. Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘In results page need to show parent not included childrens’ is closed to new replies.