Support » Plugin: Advanced Access Manager » In Metaboxes & Widgets, no “pages”

  • Resolved philos1964

    (@philos1964)


    Hello,

    When entering Metaboxes & Widgets options, I have a few options to manage but no “Pages” nor “Posts” access.

    https://ibb.co/GTyNpz7

    Thanks for your help, have a nice day!

    Philippe

    • This topic was modified 3 months, 1 week ago by philos1964.
Viewing 4 replies - 1 through 4 (of 4 total)
  • I found, on your AAM forum that message from Vasy:
    “ok, my best guess is that you have some sort of security plugin that blocks AAM ajax calls. From the past experience, I know that WordFence really likes to block a lot of plugins.”

    I am using WP Cerber. So I deactivated it, and tried to refresh the Metaboxes & Widgets options, but nothing has changed, still no Pages nor Posts in the list.

    Do I have to delete totally the security plugin to make sure AAM can call AJAX?

    I have checked the browser console (with WP Cerber activated now) and the refesh call is getting all HTTP 200… so I guess the security plugin is not the problem?

    Thanks.

    Plugin Author AAM Plugin

    (@vasyltech)

    @philos1964,

    The answer is simplier. AAM does not have the ability to control Gutenberg block and it most likely you are using Gutenberg to manage your content.

    We are following closely evolvment of the WP Gutenberg editor and as soon as they’ll have more reliable way to manage access to block, we add this to AAM core.

    Keep us posted if you have more questions.

    Regards.

    Hello Vasyl,

    No, Gutenberg is deactivated on all my websites, I’m using the classic editor.

    Using “Init URL” I got the Pages and Posts added to the list, it works now but not all is available in the metaboxes.

    On others websites I was able to deactivated the “Edit with Elementor” button from the classic Editor, but on that new website (same hosting and VPS server by the way than the others websites) I can not find that option.

    Do you have an idea about that point (or should I open another thread?) ?

    Thanks a lot.
    Philippe

    Plugin Author AAM Plugin

    (@vasyltech)

    @philos1964,

    I believe the root cause was found and the new 6.0.3 release already has the fix.

    Thank you,
    Vasyl

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.