Support » Plugin: iQ Block Country » in home “Page to redirect to” option is not working

  • hi,
    after updating this plugin to latest version I found that in plugin home “Page to redirect to:” option is not working anymore.
    Also I need you to add something similar (selecting a page) but without url redirection to that page (simply like the message to display option which is shown at the same URL)
    And the last thing which could be solved automatically if you add my previous suggestion is supporting wordpress shortcodes.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Pascal

    (@iqpascal)

    Which suggestion was that? As I can’t seem to find it.

    Having the same issue as the first one mentioned.

    I’m using V 1.2.18 – WP 6.0.1

    On the Home tab of the IQ settings, when I choose a local page to which visitors should be redirected, it doesn’t save my choice and puts in the default Forbidden message.

    Thread Starter moji_vb

    (@moji_vb)

    @iqpascal
    hello Pascal,
    The suggestion is:
    to add an option to show a user defined page contents without redirecting to that page (just print the selected page/shortcode at the same URL which visiting user is being blocked).

    Also as you may know shortcodes can be used in pages too. So its done automatically by wordpress if you include just the print selected page support.

    As a temporary fix, I tried putting the URL of the local page I need people redirected to, into the “URL to redirect to” field.

    The URL got saved, but when the redirection happens on the front end, I’m getting this error message from the browser

    The page isn’t redirecting properly
    
    An error occurred during a connection to products.com.
    
        This problem can sometimes be caused by disabling or refusing to accept cookies.

    A temporary fix that does work, is to turn the individual page where I want people from Canada to be redirected, into a non-blocked page.

    Then, in the message that shows on blocked pages, it explains that Canadians cannot access the site, but gives the URL where they can see a message for Canadians.

    Sadly, the text box for the blocked message does not allow for HTML, so I can’t make an actual link for them to click – just give them the URL and ask them to paste it in their browser.

    At least it’s something for the time being.

    Thread Starter moji_vb

    (@moji_vb)

    I applied this fix for myself by manually editing codes in “libs/blockcountry-checks.php” file arounds line 483:



    get_header();
    //echo do_shortcode(get_post($iqbc_blockredirect)->post_content);
    echo do_shortcode(get_post_field(‘post_content’, 275)); // 275 is my error message page id for unprivilaged ips
    //get_sidebar(); // breaks my theme
    get_footer();
    exit();

    hope using this code plugin author consider adding a checkbox for page redirect option to include selected page (as an html message) without redirecting and changing URL.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.