Support » Fixing WordPress » In any 3.5.x installs, visual editor does not work. Tried many, many things.

  • Resolved windd


    Hello, I seem to be having problems with the visual editor in WordPress since 3.5. I understand that this is a problem a few people have, and I have tried everything I’ve found in other threads before seeking assistance here. Any help you can provide is appreciated.

    The website in question is

    I have 10 different WordPress blogs and only 2 of them are having this problem. All the ones installed prior to 3.5 (and haven’t been upgraded) are working fine.

    The issue happens immediately upon installation. I have not changed anything from the default install.

    What happens is this: When I am in a post or page, the “Text” tab is active but there is only an “Add Media” button on the left-hand side. There are no “b i link b-quote del ins img” etc buttons. I can also see the “Visual” button, but clicking on it does nothing.

    I have tried the following:

    -Deactivated all plugins. As there was only Hello Dolly and Akismet, there wasn’t much to do.
    -I am already on the default theme, which is Twenty Twelve.
    -Via FTP, I have deleted the wp-admin and wp-includes and reuploaded them from a copy of the archive on my desktop.
    -I have added define(‘SCRIPT_DEBUG’, true); to my wp-config file. The only change that happened is that hover menus have become clear. For example, if I hover the mouse over “Pages” on the lefthand side, the contextual menu that has “All Pages” and “Add New” still show up, but you can see what it is hovering over as well.
    -Deleted .htaccess
    -Added define(‘CONCATENATE_SCRIPTS’, false ); to wp-config just after WPLANG line
    -Made sure Disable Visual Editor is NOT checked. I should also note that when I *DO* check it, I am able to see the “b i link b-quote del ins img” buttons.
    -Updated to 3.5.1. No improvement.
    -Reset the Plugins Folder via FTP (renamed folder and then reverted – per the FAQ Troubleshooting page’s instructions)
    -Installed Use Google Libraries. No improvement.
    -Installed Hotfix plugin. No improvement.
    -Cleared cache and restarted computer multiple times.
    -Removed via Fantastico and reinstalled.

    I am very nervous about the thought of playing with database files. I don’t know how they work and the one time I’ve tried I irrevocably destroyed a blog. If we can avoid playing with myPhPAdmin, that would be preferable.

    I still have a copy of 3.4.2 in a .zip on my computer, and would be willing to just install that but I don’t really know how to do that without causing problems. Could I just copy the 3.4.2 wp-admin and wp-includes via ftp and leave the wp-content and database alone?

    Errors from browser:
    –From trying to edit an existing post:
    Uncaught TypeError: Cannot call method ‘add’ of undefined

    –From trying to edit an existing post in Draft status:
    Uncaught TypeError: Cannot call method ‘add’ of undefined

    –From trying to edit the Hello world! post that comes with wordpress
    Uncaught TypeError: Cannot call method ‘add’ of undefined

    –From creating a new page:
    Uncaught TypeError: Cannot call method ‘add’ of undefined

    –From creating a new post:
    Uncaught TypeError: Cannot call method ‘add’ of undefined

    —-NOTE—- Whenever the Visual button is pressed when trying to edit an existing post, this error appears:
    Uncaught TypeError: Cannot read property ‘canvas’ of undefined quicktags.min.js:1
    c.closeAllTags / quicktags.min.js:1
    switchEditors.go / editor.min.js:1
    switchEditors.switchto / editor.min.js:1
    (anonymous function) / post.php:257
    onclick / post.php:258

    I do not think this is a browser specific as I am able to open a different blog’s admin panel in the very same browser and can have both open at the same time on side-by-side tabs.

    All of my blogs are installed on the same host, and as mentioned, the older, un-upgraded installs are working fine. They are all running on WordPress 3.3.2 except my very first one which is 3.0.3. It is only the 3.5.x that are not working properly.

    Browsers I have tried: Dragon 25.2 (Chrome-based), Rockmelt, IE 9.0.8, Firefox 19.0.2, Chrome 25, Safari 5.1.7, Lunascape 6.7.1 (both Chrome, Webkit and IE modes)

    I am using Windows 7 Home Premium SP1 64-bit.

    I have also tried accessing from my husband’s computer to no success.

    This was the only information in the .htaccess before I deleted it. (I did make a backup as well)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    NOTE: To others experiencing this problem, please do not add to this thread. Please make your own thread and spell out anything/everthing you’ve tried. Thank you for your consideration.

    I hope I have provided enough information. Thank you again for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I am confused…that was a multiple hundred line post….what was your domain name again?

    Have your web host set your directory permissions for you!

    They need to issue a “chown -R” on on the root path to the directory that your site files are in. And then check the permissions with FTP.

    Apache Example: (I don’t use apache so I’m guessing)
    chown -R apache:apache /var/www/

    Nginx Example:
    chown -R www-data:www-data /var/www/

    You host should know how to do this and it should fix the problem.


    Hello, I appreciate the suggestion by cbunting99 however my host provider is telling me that I have to switch from DSO to suPHP and uninstall eAccelerator in order to make this change. I am VERY hesitant about doing this. They are explaining to me that this will significantly reduce the speed of *all* my blogs, which I cannot afford to do, as I have many and some of them are quite popular (and working fine).

    Thank you all for your help. I have solved this problem. What I did is:

    -Find an older .zip of WordPress (I had 3.3.1 from long ago)
    -Removed the wp-admin and wp-includes folders via FTP
    -Copied the wp-admin and wp-includes from my local 3.3.1 zip via FTP back to my install
    -Copied all the .php files from the zip to the install.

    It asked me to “update” my database, which I allowed it to do, and everything seems to be working fine. I am able to see the visual tab and make edits with no problems. The only negative thing that happened was that I had to set my background back up, but that’s no big deal.

    It’s not likely that I will be updating any time soon.

    As I had mentioned, it was a permission issue. Sometime on certain systems when u auto upgrade, you inherit the settings from the developer machine. Your host should read, as it would have solved your problem in 5 seconds.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘In any 3.5.x installs, visual editor does not work. Tried many, many things.’ is closed to new replies.