Support » Fixing WordPress » In 2.1, I can’t create or edit published Pages, or delete Posts or Pages

  • I’ve posted about this problem on my blog, with screenshots, here:
    http://www.brendanloy.com/2007/02/wordpress-21-upgrade-problems.html

    Last night I attempted to upgrade my blog from WordPress 1.5.2 to WordPress 2.1. However, I ran into a couple of problems that I haven’t figured out how to solve.

    First of all, my server meets the minimum requirements for WordPress 2.1: I’ve got PHP 5.0.3 and MySQL 4.1.9. And I followed the detailed upgrade instructions to the letter, including deactivating all plugins, so that’s not the issue.

    Here are the problems I’m haivng:

    1. I can’t delete posts.

    On the Manage Posts page, the “Delete” link, which should be immediately to the right of “Edit,” is missing. And it’s not just that screen. On the individual post editing screen, the “Delete this post” button is there, but when I click it, and click OK on the confirmation dialog, I get the error message: “You are not allowed to delete this post.”

    This seems like some sort of issue with permissions between the MySQL database and the WordPress interface. I can delete posts in phpMyAdmin without any problem, but I can’t delete them via WordPress. Unfortunately, I have no idea how to solve it. But I suspect it’s related to…

    2. I can’t create published Pages, or edit published Pages that already exist.

    This seems to be the same problem that’s already been noted here (http://wordpress.org/support/topic/104376), but here’s a somewhat more detailed description. In the Pages interface, there is no “Published” option under Page Status. As a result, I can’t create functional Pages through the WordPress interface. I can create draft Pages and “private” Pages, but no publicly accessible ones.

    In phpMyAdmin, I can convert draft/private Pages that I created in WP into published ones by changing the “post_status” field to “publish.” But the, on the Manage Pages screen, not just the “Delete” option but the “Edit” option disappear! And when I try to manually go to the “Edit” URL, I get the error message, “You are not allowed to edit this page.”

    Also, regardless of whether the Page is published, a draft, or private, I can’t delete it through the WordPress interface, just like with Posts.

    Does anyone have any suggestions for how to fix these problems? Has anyone else experienced any of this?

Viewing 15 replies - 1 through 15 (of 20 total)
  • It appears these problems only occur when you upgrade directly from WordPress 1.5.2 to WordPress 2.1. I tried upgrading incrementally, from 1.5.2 to 2.0 to 2.0.7 to 2.1, and I didn’t have the same problems.

    @trojanloy:

    Your statement is incorrect. I upgraded from 2.0.5 and have the same problem where I cannot delete a Page.

    Geekninja, perhaps you might try upgrading from 2.0.5 to 2.0.7 and *then* to 2.1? That would most closely simulate the incremental upgrade that worked for me.

    Why does the title of this thread have [resolved] in it when the problem is not resolved? If it truly resolved, please post the resolution? So many people are having this problem, and no one seems to have a definitive solution.

    I figured this one out. My .htaccess file hadn’t been copied from the old installation. Copying that file (or clicking “Update Permalink Structure” under Options, Permalinks) fixed the problem for me.

    I had to manually delete my .htaccess file and then click update permalink structure. That seemed to do the trick for me.

    I’m having the same issue, and I tried the update permalinks structure thing, and I still can’t get it to work.

    Um. I also had the problem. that’s because of incorrect role upgrade for wp_option table.

    If you can edit your DB, Insert below on the record,wp_user_roles’s option_value of option_name field in wp_post table.

    ———————————————————–
    a:5:{s:13:”administrator”;a:2:{s:4:”name”;s:13:”Administrator”;s:12:”capabilities”;a:47:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:6:”import”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:8:”level_10″;b:1;s:7:”level_9″;b:1;s:7:”level_8″;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;s:12:”delete_users”;b:1;s:12:”create_users”;b:1;}}s:6:”editor”;a:2:{s:4:”name”;s:6:”Editor”;s:12:”capabilities”;a:34:{s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;}}s:6:”author”;a:2:{s:4:”name”;s:6:”Author”;s:12:”capabilities”;a:10:{s:12:”upload_files”;b:1;s:10:”edit_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:4:”read”;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;s:22:”delete_published_posts”;b:1;}}s:11:”contributor”;a:2:{s:4:”name”;s:11:”Contributor”;s:12:”capabilities”;a:5:{s:10:”edit_posts”;b:1;s:4:”read”;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;}}s:10:”subscriber”;a:2:{s:4:”name”;s:10:”Subscriber”;s:12:”capabilities”;a:2:{s:4:”read”;b:1;s:7:”level_0″;b:1;}}}
    ———————————————————–

    good luck.

    It’s my fault that the topic is marked as “resolved.” I created it, and then changed its status to “resolved” because it was, for me, resovled by upgrading incrementally, from 1.5.2 to 2.0 to 2.0.7 to 2.1. However, since that solution doesn’t seem to resolve the problem for everyone, I’ll changed its status back to “not resolved.”

    For the record, the .htaccess solution definitely didn’t work for me. That was one of the first things I tried. I don’t know whether elpis2000’s suggested changes to wp_options would have done the trick… since I’m no longer having the problem (thanks to my incremental-upgrade solution), I can’t test it.

    Anyway, good luck to everybody who’s still having this issue…

    YES!!It did the trick!!
    Elpis, that was smashing. I’ve been trying to solve this for a week.
    Thanks a lot man.

    Unfortunately none of the above worked but a fix suggested at http://trac.wordpress.org/ticket/3807 did work for me.

    When I couldn’t get my wordpress installation working using the information above I tried a completely new installation and kept having the same problems. This fixed as resolved the issue on both the upgraded installation and the fresh install. So happy right now, thought i was going to have to delete my blog and start all over again.

    Hi, elpis2000, I can’t follow your method. Can you give more detail instruction? What’s your means of “Insert below on the record,wp_user_roles’s option_value of option_name field in wp_post table.”?
    I don’t have wp_post table(there is a wp_posts table, but they all are posts)

    Oh, I know it.

    Search wp_user_roles in DB will find the item, change it to given strings, the problem is solved.

    Thanks to elpis2000

    Thank you Elpis200!

    This worked for me. Thank you!

    I don’t have a wp_user_roles table in my WP database. Should I have that on a clean 2.1.2 installation or is it just slug from old installations? If I’m supposed to have it, where have it gone and why (I surely haven’t deleted it on purpose and it isn’t on any of my other WP installations either). If I’m not supposed to have it, then surely modifying it according to elpis2000’s tip won’t help.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘In 2.1, I can’t create or edit published Pages, or delete Posts or Pages’ is closed to new replies.