Support » Plugin: WP Mail SMTP by WPForms » Improved Security

  • Resolved pedrorafael

    (@pedrorafael)


    Hi,

    first of all, congratulations to the plugin.

    I wanted to leave a question for you:

    – When I enter the code below in the wp-config.php file, the emails are not sent and causes the site to load, load and load, consuming lots of server resources and finally leaving the whole site offline.

    define (‘WPMS_ON’, true);
    define (‘WPMS_SMTP_PASS’, ‘your_password’);

    – The interesting thing is that I remove the above code and everything returns to normal.

    Would you have any suggestions as to what might be causing this problem?

    Thank you,

    Pedro.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    Make sure that the constant names are actually properly included in ' (single quote).

    Here is that:

    
    define ( 'WPMS_ON', true );
    define ( 'WPMS_SMTP_PASS', 'your_password' );
    

    I assume you made a test using Email Test tab in plugin settings, correct?

    Plugin Author Slava Abakumov

    (@slaffik)

    Also, please try to check this solution:

    https://wordpress.org/support/topic/v-1-0-0/page/2/#post-9776623

    It might or might not fix your issue, but it’s definitely worth a try, as we have users reporting that worked for them.

    Hi @slaffik,

    yes I used the email test to verify the code in question.

    The good thing is that without using the code to increase security, the plugin continues to deliver on all emails correctly on all client sites I use.

    And I tested the solution that you indicated to me, but it did not work unfortunately.
    https://wordpress.org/support/topic/v-1-0-0/page/2/#post-9776623
    The problem continues and overloads the server and everything goes offline.

    Thank you,

    Pedro.

    Plugin Author Slava Abakumov

    (@slaffik)

    Constants usage was already fixed and released.
    Also a new option – Auto TLS – was introduced, so it’s better to test against the newer version.

    Meanwhile, I’m marking this topic as resolved (as an initial constants issue was fixed in 1.1.0).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Improved Security’ is closed to new replies.