Support » Plugin: Remote Media Libraries » impossible to save RML settings

  • Resolved berteh

    (@berteh)


    Hello.

    Thanks for the plugin.

    I cannot configure any Remote Library in WP4.7.3 on php7.1: each time I configure and validate a service (vimeo, flickr or other), clicking on “save” or “update” post leads to a blank page… and no saved library.

    enabling debug in WP leads to the following messages being printed:

    Warning: Illegal string offset ‘service_class’ in /home/sto/wordpress/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150

    Warning: Illegal string offset ‘vimeo_remote_user_id’ in /home/sto/wordpress/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150

    … and similarly for each of the provided services types.

    seems like you’re trying to access a key in the array that does not exist, not sure though: http://stackoverflow.com/questions/22279230/how-to-fix-warning-illegal-string-offset-in-php

    I’m available to test any fix you may propose, if that helps.
    B.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi, I’m also stucked the same problem which can’t create any media library entries. My environment is also RML 1.4.0 on WP4.7.3 and PHP 7.1. Dumped error is here:

    
    
    Warning: Illegal string offset 'service_class' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'vimeo_remote_user_id' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Cannot assign an empty string to a string offset in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'service_class' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'youtube_remote_user_id' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Cannot assign an empty string to a string offset in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'service_class' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'dailymotion_remote_user_id' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Cannot assign an empty string to a string offset in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'service_class' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'flickr_remote_user_id' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Cannot assign an empty string to a string offset in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'service_class' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'instagram_remote_user_id' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Cannot assign an empty string to a string offset in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'service_class' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Illegal string offset 'isValid' in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Warning: Cannot assign an empty string to a string offset in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 150
    
    Fatal error: Uncaught Error: Call to a member function validate() on null in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php:257 Stack trace: #0 /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/MetaBoxSaveAccount.php(46): WPRemoteMediaExt\RemoteMediaExt\Accounts\AbstractRemoteAccount->validate() #1 /home/users/0/__masked__/web/wp1/wp-includes/class-wp-hook.php(300): WPRemoteMediaExt\RemoteMediaExt\Accounts\MetaBoxSaveAccount->action(5800, Object(WP_Post)) #2 /home/users/0/__masked__/web/wp1/wp-includes/class-wp-hook.php(323): WP_Hook->apply_filters(NULL, Array) #3 /home/users/0/__masked__/web/wp1/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home/users/0/__masked__/web/wp1/wp-includes/post.php(3505): do_action('save_post', 5800, Object(WP_Post), true) #5 /home/users/0/__masked__/web/wp1/wp-includes/post.php(3578): wp_insert_post(Array, false) #6 /hom in /home/users/0/__masked__/web/wp1/wp-content/plugins/remote-medias-lite/src/RemoteMediaExt/Accounts/AbstractRemoteAccount.php on line 257
    

    @loumray Do you mind looking our problem and giving some feedbacks??

    • This reply was modified 2 years, 10 months ago by everpeace.
    • This reply was modified 2 years, 10 months ago by everpeace.

    Hey Guys,

    Thanks for using latest PHP version and taking time to report the error with proper details.

    I just released version 1.4.1 which should solve this issue.

    Cheers,

    L-M

    @loumray Thanks!! 1.4.1 works perfectly! I can save remote media library entry.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘impossible to save RML settings’ is closed to new replies.