Support » Plugin: Ultimate Member - User Profile & Membership Plugin » Impossible to save changes in email templates

  • Resolved clicks11

    (@clicks11)


    I have been using this UM plugin (the free version) for almost two months without any issues. Today, I wanted to change an email template (Ultimate Member / Settings / Email) but I’m unable to save changes. Impossible for any of the templates. When I click the [Save Changes] button I’m getting one of two error messages:

    On a freshly installed WordPress without any plugins:
    Forbidden
    You don’t have permission to access /xxxxxxxxxx/wp-admin/admin.php on this server.
    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    On a live website:
    404 message handled by the WordPress offering search.

    I’m hosting on NameCheap with ssl, and as far a I remember, I was able to save modified email templates about three weeks ago.

Viewing 8 replies - 16 through 23 (of 23 total)
  • Thank you for the tips, but I am using cPanel on Linux server. Different config I guess.
    This is very troublesome. I have exported and imported the modified templates via FTP. I have saved a copy of them on an External drive. I wish this company could respond to my request. I have bought one of their plugins.

    Hi mate,
    I’m glad to help. Been using this plugin for a few years now.
    What exactly is your issue?

    Could dsomebody from the tech department contact me ASAP? It has been a week since I am waiting for an answer. I need to be able to change the email subjets of each template. I am working in French. I keep on getting this Error 404. This is really frustrating. Not getting any help is even more stressful.

    @dionysios, I am working on Linux CPanel server. I guess the configuration is different from Windows server.

    OK, I have found out that your templates should be moved to your child-theme. From there you can modify the templates subjet line within WP CM. Also you can update the templates content via FTP. You have to make sure your templates are within your child-theme folder and not in your main theme, otherwise you will loose any updates when upgrading your plugin.

    clicks11

    (@clicks11)

    Although Ultimate Member has already been replaced by a different membership plugin in my particular project, I’m still getting notifications from this thread.

    The workaround might be turning off the ModSecurity WAF. On shared hostings, you can do it either in cPanel by yourself or if your provider removed that option (NameCheap in my case), you might need to contact them and ask to turn off ModSecurity. This worked for me when I was getting 404s while saving Mailster campaigns.

    @clicks11 What did you end up going with instead of UM since they aren’t getting it together for this issue?

    @carsonthetford I ended up using Simple WordPress Membership. Not as feature rich as UM, but working just fine for that particular project.
    If you are on a shared hosting, you might try turning off the ModSecurity WAF (in cPanel or asking tech support). This solves similar issue not saving the templates I had in Mailster. I curious if that works for UM as well…

    @clicks11 I worked with my hosting provider (also namecheap) to try the ModSecurity trick and they were able to whitelist it for me. That did fix it. Thanks for the help!

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.