Support » Plugin: Login IP & Country Restriction » Impossible to load admin login page after updating the plugin

  • Resolved misselenat

    (@misselenat)


    Hi there,
    I wanted to notify you about an issue I’ve had since updating the plugin to the latest version (I had been using it for more than a year without any issues).
    Basically, my website keeps loading fast and working as usual, but I can no longer open the WP login page. I have been using the plugin with country restrictions (allowing my country alone). There have been no changes to either my computer, my connection or anything else.
    What happens right now is that the login page keeps loading without showing up, or loads after 3-4 minutes. Meantime, the resources on my hosting are highly used, as the page keeps sending requests in order to show up.
    To troubleshoot the problem, I have first disabled all of the plugins, and noticed the login page was working again as usual. Then I have started activating the plugins one by one, and yours was one of the last I added. Of course I did several tests and everytime all plugins were activated, the login page was not working. As soon as I disabled yours (via File Manager), things were working again as usual.
    I don’t think it has a conflict with other plugins, because they are the same ones I have been using for months, together with yours, without any issues (I guess a conflict would have appeared sooner).
    Right now I had to disable the plugin, so it’s useless to give you my website’s link. Also, for security reasons, I use a custom login page (not the usual login.php). But like I said, everything had been working like a charm for more than a year.
    I don’t know if there is anything you can do to check why the new version is giving such problems; I certainly loved the old one and would install it again if the problem was fixed.
    Thank you for anything you can do about it!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Iulia Cazan

    (@iulia-cazan)

    Hi,

    Thanks for letting me know about this, I will look into it. What PHP and WPcore versions do you have? Also, are you using Cloudflare?

    Regards,
    Iulia

    Thread Starter misselenat

    (@misselenat)

    Hi Iulia,

    Thank you very much for your reply and for your help.

    Here are the details you requested:
    PHP version = 7.4.16
    WordPress Version = 5.7.2

    I’m not using Cloudflare or other CDNs.

    Please let me know if you need any other information. I’d be glad to help fix the issue, so if you come up with a possible solution and want me to test the plugin on my website before releasing a new update, just let me know.

    Thank you again for looking into the matter!

    Best Regards,
    Elena

    Plugin Author Iulia Cazan

    (@iulia-cazan)

    Hi,

    Please upgrade and let me know if you still replicate the issue, I made some compatibility fixes.
    If this is still an issue, please check the new tab from the plugin setting for “debug” and provide me with the info you have there. The info should not be shared publicly here, you can contact me directly on my website through the contact form.

    Have a nice evening,
    Iulia

    Thread Starter misselenat

    (@misselenat)

    Hi Iulia,

    Thank you very much for working on the issue!

    I have just updated the plugin and it looks like everything is working fine again, just like it used to. I have tested it both “normally” and incognito on my browser, and each time the login page appeared in less than a second. I also used a different browser and tried typing the URL on my mobile phone – everything works like a charm.
    I will let you know in case I notice anything strange, but it really looks like you have solved the issue!!!
    Thank you so much for your help. I will leave a positive review and 5-stars rating right away!

    Have a great evening,
    Elena

    Thread Starter misselenat

    (@misselenat)

    P.S. I had already left a review more than 1 year ago, with 5 stars of course – it’s a pity I can’t write another one, so I encourage everyone who is enjoying this plugin to take a moment to express their appreciation! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.