Support » Plugin: Maps Builder - Google Maps Plugin » Impossible to edit in Maps Builder

  • Hi there,

    I’m using the free version of the plugin, and I used to be able to modify or add pins to my map but somehow I have access to nothing when I click edit on my map.
    I used the Health Check plugin. Deactivated every plugin and tried and yet nothing.

    Here’s a screenshot of what I get:
    screenshot

    Please if you know anything I can do. I’m up to date with all my plugins and themes.

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Matt Cromwell

    (@webdevmattcrom)

    Hi there,

    Here’s two options to find the source of the problem:

    1) With HealthCheck you can also change your THEME. Try that to see if the theme is the source of the problem

    2) Right click on the screen and choose “Inspect” (different browsers say different things, but that’s the most common name), then there should be a tab called “Console” and it will show errors. If you can provide a screenshot of the Console that would be helpful.

    Thanks!

    Hi Matt,

    Looks like there is something preventing to load so JS:

    https://chunky.nz/wp-content/uploads/2018/09/Capture-1.png

    And I tried to change theme but yet nothing has changed.

    Same issue here.

    TypeError: $(...).qtip is not a function

    Has worked before. Disabling all other plugins didn’t worked.

    I use a custom made theme, but MapsBuilder has worked before. I assume it has to do with a new WP version, since it is only in the backend.

    It seems to work with php 5.6.38 but not with php 7.2.

    Same problem 🙁

    After a scan by PHP Compatibility Checker:

    Maps Builder – Compatible – Warnings: 3

    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————-
    220 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

    OUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————-
    224 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ——————————————————————————————————————————-

    On my site I need to update the maps everyday.
    What do I have to do now? To wait for an updating arriving soon or to look for an alternative pluging working with PHP 7?

    Let me know asap please. Thank you.

    Marius Sonnentag

    (@about2press)

    For me it works with php 7.1 but not php 7.2. With 7.2 it works in the Frontend but not in the Backend – not loading as described above.

    See for JS Error: https://cl.ly/51536bc807e1

    So an update for the Plugin with php compatibility 7.2 would be great for the near future 😉

    I had this problem in a Multisite install, where on every Installation it worked but not on one site (settings all the same on every Website). Then i checked the php Versions and – oh this is the only one (that was not working in the Backend) running with php 7.2… so i switched back to php 7.1. and now it works!

    @webdevmattcrom Your embedded CMB2 includes need to be updated to at least v2.3.0, which includes compatibility fixes for PHP 7.2. Generally, the errors are along the lines of:

    Fatal error: Declaration of CMB2_Type_Textarea_Code::render() must be compatible with CMB2_Type_Textarea::render($args = Array) in /Users/coryhughart/Dev/web/onx.com/htdocs/wp-content/plugins/google-maps-builder/vendor/wordimpress/maps-builder-core/includes/libraries/metabox/includes/types/CMB2_Type_Textarea_Code.php on line 13

    For those waiting on this fix, I downloaded CMB2 v2.3.0 and dropped the files into the plugin at google-maps-builder/vendor/wordimpress/maps-builder-core/includes/libraries/metabox/. It would probably make sense to include a more recent version, but this was closest to the version embedded into this plugin with the PHP 7.2 fixes.

    @cr0ybot Also of note, you can simply install the CMB2 plugin, and it will override the older versions.

    @jtsternberg Than you! I have confirmed that installing CMB2 fixes the issue without having to edit the plugin code. I’ve been peppering this forum with this solution since the announcement that the plugin will no longer be supported.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Impossible to edit in Maps Builder’ is closed to new replies.