Support » Fixing WordPress » Impossible to Disable Comments

  • I am having problems with two installations of WordPress on the same server. One of them was 1.5 and the other 2.0 and updating to the latest version today did not help with the problem.

    I am under a comment spam attack and I decided to disable commenting entirely until I have time to install and test a proper comment spam solution. I have disabled comments in the Admin panel and updated all of the posts with the comment status as ‘closed’. I have removed the wp-comments-post.php from the blog’s root folder and the comments.php and comments-popup.php from the themes I use, and I still get regular comment spams. How can this be possible?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    They are not comment spams. They are trackback spams.

    Install Bad Behavior and Akismet. They work. And you won’t have to disable comments.

    Thanks for the tip. I have installed and configured Akismet and Bad Behaviour and reactivated comments. Now time will tell if it will solve the problem…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Impossible to Disable Comments’ is closed to new replies.