Support » Plugin: SSL Insecure Content Fixer » Impossible to desactivate without errors…

  • Resolved uwaika

    (@uwaika)


    Hello,

    When I try to desactivate this plugin everything goes wrong… I have too Many Redirections Error and I have to put my backup (file and database).
    It’s like I’m trap with this plugin 🙁
    Can you help ?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author webaware

    (@webaware)

    This plugin does not make any changes to your website, it only converts bad links into good links while it is running. If you have changed your website settings to https (Settings > General) then you will need to clean up your content with something like Better Search Replace as described on the documentation site:

    https://ssl.webaware.net.au/testing/cleaning-up-content/

    cheers,
    Ross

    uwaika

    (@uwaika)

    Thanks you, but how do you explain that when I try another option than “Simple” like “contenu” or “desactivate” everything goes wrong.
    Or if i try Détection HTTPS with the “WordPress option” it’s also broken. (sorry my plugin is in french).

    I will take a look to better search and replace, but I’ve already check my urls..

    Marc,

    uwaika

    (@uwaika)

    I try to desactive all others plugins. My Website is fine. And when I try to desactivate this one, I’ve got an error.
    I’ve tried Better Search but all of my links seems to be fine 🙁
    Here is what the SSL Test is saying :

    Test terminé.
    Il semblerait que votre serveur soit derrière un proxy. L’option recommandée pour le protocole HTTPS est HTTP_X_FORWARDED_PROTO.

    L’environnement de votre serveur affiche ceci :

    Array
    (
    [HTTP_SEC_FETCH_MODE] => cors
    [HTTP_SEC_FETCH_SITE] => same-origin
    [HTTP_X_FORWARDED_PROTO] => https
    [HTTP_X_FORWARDED_FOR] => 82.248.96.69
    [REQUEST_SCHEME] => http
    )

    I still don’t know what to do next :'(

    Plugin Author webaware

    (@webaware)

    G’day Marc,

    Détection HTTPS should be set to the setting that the plugin recommends. e.g. if it recommends HTTP_X_FORWARDED_PROTO then please select that setting. If you don’t, then WordPress will not know when your website is loaded on https and you could get Too Many Redirections errors.

    Deactivating the plugin can also give you those errors if you have changed your website Home and Site URL to https, because WordPress can’t tell when you’re on https and will redirect you to https endlessly.

    If you want to remove this plugin safely, you will need to modify your wp-config.php file. In your case, you can add this to your wp-config.php file near the top:

    if (isset($_SERVER['HTTP_X_FORWARDED_PROTO']) && strtolower($_SERVER['HTTP_X_FORWARDED_PROTO']) === 'https') {
    	$_SERVER['HTTPS'] = 'on';
    }

    cheers,
    Ross

    uwaika

    (@uwaika)

    Thanks you, your code saved me 🙂

    Have a nice day !

    Marc,

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.