Support » Plugin: Appointments » Impossible to connect to Google Calendar even with WPMUDEV admin direct support

  • Hello,

    The WPMUDEV Appointments plugin has a LOT of promise.

    I carefully set it up using a checklist with each specific element identified (following the plugin’s setup directions).

    The setup failed to connect to the Google calendar.

    So I tried it using a different, new (empty) Google Calendar with a different email address.

    After failing and banging my head against things I gave up and contacted WPMUDEV Support and created a ticket–I’m a member there.

    After being handheld through the setup again–and still failing, I gave the WPMUDEV Support rep admin access to my site to set it up.

    Fail.

    First, it’s INCREDIBLY COMPLEX to connect the plugin to Google Calendar.

    Nxt, at the time I did this the Google Calendar (API?) interface no longer matched the plugin setup instructions. Even with this I was able to try this, try that and find the places I was supposed to use to set this up.

    Finally, after days and days of trying to get this to work, one hour here a couple of hours there, I stopped. The plugin doesn’t work out of the box every time (for everyone).

    I went to TimeTrade and had this working with my Google Calendar in about 30 minutes.

    However, I strongly dislike the fugly TimeTrade (1995) UI/UX – it’s horrible and cannot be tuned to match my site.

    But back to this plugin.

    This is one of those places where the massive WPMUDEV Support desk is needed. Setting this up is not for the technically challenged.

    Chris

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey Chris,

    Thanks for your feedback here.

    Are you referring to this thread? https://premium.wpmudev.org/forums/topic/appointments-google-api-issues#post-882948

    I was going over it and I see that you offered to provide us your gmail login info so we could get it setup for you ourselves; however, that was never sent in or at least never made it into our inbox.

    We are more than happy to help you further with this. If you want to contact me here: https://premium.wpmudev.org/contact/

    Select “I have a different question” and make the subject line “Attn: Tyler Postle“.

    If you’re happy with your new solution then no problem at all, just let us know if you ever do re-visit Appointments+ and I can get it all setup for you.

    Hope you enjoy the rest of your day!

    Hey Tyler,

    Thank you for the follow up.

    You guys in WPMUDEV SUpport are awesome and 90%+ of the plugins are really, really good.

    It’s the exceptions like this that keep WPMUDEV Support so busy with thousands and thousands of support tickets that can be mitigated by re-developing plugins, or their interfaces, whenever a repeat user issue appears more than three times on one plugin.

    Yes, that’s the thread.

    If you’ll carefully re-read that thread
    (see Ashok’s post Sun May 10, 2015, 6:59:22 AM)
    you’ll see that I did in fact give the full network admin and SFTP access to the site.

    And that Ashok, WPMUDEV support, was able to login, create a test subsite on the network, AND get that test site to connect to a calendar AND sync appointments.

    So it works on a test site and a test calendar.

    However, I’m not running my business on a test site, nor a test calendar and it is impossible to set it up on my subsite and my Google calendar… as seen in the long thread where I carefully, carefully, and explicitly identified all of the steps and where things fail in the setup.

    E.g.

    (Wed Apr 22 2015, 11:08:44 PM)

    “The first issue is that the Google APIs interface has changed and the WPMUDEV instructions do not match the new UI.”

    “Next when I got to steps 18 and 19 Google prevents this required setting:

    18. Set “Permission Settings” of this person as “make changes to events”.

    19.Click “Add Person”.

    After clicking Add Person Google adds the email address but changes the Permission Setting to be:

    “See only free/busy (hide details).”

    And this cannot be edited or changed. I tried deleting the new user/email and adding it again but it still defaults to this permission.

    With no option but to move forward with that setting (limitation?). I moved on with the instructions and created the calendar (step 20).”

    Already, at this point of failure, the plugin needs to be revised. ANd at a failure point like this where a setting cannot be set as specified in the instructions, the entire setup should stop due to the failure and the failure should be resolved by the plugin developer.

    Continuing…

    “Steps 26 and 27:

    26. After these stages, you have set up Google Calendar API. To test the connection, click the “Test Connection” link which should be visible after you clicked save settings button.

    27. If you get a success message, you should see a test event inserted to the Google Calendar and you are ready to go. If you get an error message, double check your settings.

    I saved the settings and then clicked the Test Connection link.

    The page refreshed with no error or success messages. I’m left to guess if it’s working or not. I assume from no error messages that it’s working. But because no event appeared in the calendar (as the instructions stated it would)–I don’t know.

    And the instructions don’t state WHERE/WHEN the appointment will be set. I’m guessing that the test appointment would be set right now. But who knows? It doesn’t appear in the calendar.”

    and

    (Mon May 4 2015, 7:57:28 AM)

    “I created a unique Google Calendar for the plugin, per the instructions–it’s not using my main calendar, and no other application is using this unique calendar.

    I’ve never been able to get an appointment to come across to the calendar.

    The site is hosted on WP Engine, which has CURL enabled and not restricted.”

    And when WPMUDEV Super Support rep (and nice guy) Ashok, shared a How To video screencast, I followed it but…

    (Tue May 12 2015, 1:24:14 PM)

    “Thank you Ash.

    Your video helped me do the correct steps, step by step. All the steps in the video worked and saved but the new app and the new calendar don’t work together.

    I’ve created two new appointments and they do not appear in the NEW calendar I created.”

    and

    (Tue May 12 2015, 1:35:50 PM)

    “I don’t see instructions but I remembered something about putting the .p12 file on the server. I went through the Appointments plugin folders and found the Key folder with my previous key and your test key. I added the new .p12 key file in there.

    But I don’t know what to do with the other file, the .json file.

    And when I click the Test Connection key now there is no message on the Settings page when it refreshes, and no appointment is made in the new calendar (as it says it will be).

    Also I clicked the ” Import and Update Events from GCal Now” button (Clicking this link will manually import and update your Events from the selected calendar without waiting for 10 minutes. )

    But when I refresh the calendar nothing is there, not the three appointments I made and not the test appointments said to be created by the Test Connection link.”

    …and finally, I gave up after this last attempt:

    (Thu May 14 2015, 8:55:18 AM)

    “Thank you Ash!

    Now I see the full instruction set.

    However I’m unable to get Appointments+ working.

    I followed your video (which was GREAT).

    I uploaded the key file to the key folder via SFTP.

    And it will not do test connection appointments nor will it do appointments from the front end.”

    I did ask for Ash’s help but realized I was continuing to try and get something working that won’t work, and if it did start to work I’d be afraid of it breaking down the road due to the maximum difficulty and numerous, sequential failures trying to get it going in the first place.

    Maybe it would be possible if I just kept trying it and trying it and trying it as I did, as seen in the ticket. That’s not my purpose in life.

    If I buy a car and it dies as I pull away from the car dealer I’m not going to keep taking the new car to mechanics to TRY and get it to work.

    I move on to a car that works.

    The WPMUDEV Appointments plugin did not fulfill the WPMUDEV promise that all plugins will work. That promise implies that the plugin end user can follow the instructions (even though in this case they are complex, lengthy and absolutely fail in some instances as detailed in that long thread).

    Most casual WordPress implementers/users would be shocked if they saw the 30 point instruction set that must be followed to set this plugin up (even though it fails to correctly instruct in some cases).

    I gave up after so many days and hours spent TYRING to get it to work and failing.

    I can’t imagine why after a month of trying on and off to get something working I would continue to rely on it for my business.

    APIs are super prevalent today everywhere and especially in WordPress.

    If the WPMUDEV Appointments plugin would use an API and a few clicks and input fields from within the plugin, and cause the Google Calendar pop-up to appear where Google Calendar asks if the app can have permission (as happens in every other case where I add something to Google Chrome), then this plugin would be awesome. Especially if after the easier, new and improved set up–things worked.

    However, as clearly evident in the WPMUDEV thread, the plugin is a nightmare to set up with pages and pages of complex instructions, SFTP actions, plugin settings and Google settings to go through.

    I’ve set up LinkedIn, Facebook, Twitter, single sign on, and many Google apps using each of their APIs to connect the apps to WordPress websites and they’re all 10 times easier to do. That factor could even be 100.

    And finally, one nail in the WPMUDEV Appointments plugin coffin is this:

    “About the gcal, is it your primary calendar? You must not use primary calendar as your appointment calendar.”

    WHY would I want appointments to appear in some other calendar besides my main calendar?

    Appointments should appear in MY calendar so that I can manage them with all other activities rather than referencing a second calendar, or even trying to integrate a second calendar’s view overlapping with my main calendar’s view.

    That last bit didn’t stand out so much when I was neck deep in trying to get it all setup.

    If I can perhaps humbly offer a solution to this problem I’d have the WPMU developers look at how easy it is for other plugins to connect to LinkedIn developer, Twitter, Facebook developer and especially other Google developer apps.

    The I’d redesign the plugin so that the end user doesn’t need to follow the long list of deep instructions. Instead the end user of the plugin would set up everything using a UI User Interface inside of the plugin’s admin settings where Google would pop up a permissions screen much like every time you add an app to Google Chrome.

    Failing that simple process I’d set up the plugin with a much more simple instruction set and make the end user’s life easier by changing how many steps there are within the plugin and inside of Google developer tools.

    I’d be so disappointed if I had to support this plugin.

    Chris

    Hey Chris,

    Thanks for the thorough response here and I’ll definitely admit that some of the Appointments+ features need a rewrite. We’re actually planning on rewriting the whole plugin as well to make it more user-friendly. It’s one of our more popular plugins.

    In my last response I was referring to the gmail access:

    So rather than paying for a custom developer to do the work, I’ll get you the login info to my Gmail account to use for this calendar.

    That’s from this post here: https://premium.wpmudev.org/forums/topic/appointments-google-api-issues#post-882831

    We were waiting for the gmail access to come in but I don’t see any emails where that came in? Our system closes the support tickets once staff reply then re-opens them again once the member replies back, so since there was no reply in the ticket and an email with the gmail access never came in, the ticket was left closed.

    So if you do re-visit it later on then let us know and instead of all the back and forth troubleshooting, we’ll just get that access and set it up for you right away. I’ve probably setup the gcal integration about 100 times now 😀

    Or even better, when you revisit it we may have an updated integration!

    Thanks again for your feedback here. Any further questions/comments just let me know.

    Hope you have a great weekend.

    How scary to grant my email access to a third-party just to get a damn plugin to work! Send my email password to a total stranger? Seriously?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Impossible to connect to Google Calendar even with WPMUDEV admin direct support’ is closed to new replies.