Support » Fixing WordPress » Impossible to add spaces between paragraphs in Classic Block

  • Resolved misaka1

    (@misaka1)


    Hello,

    I have been having persistent issues for past weeks with adding space between paragraphs in Classic Block.

    As depicted here, the spaces are in place. If I click on preview, this is what I get in reality instead. Not only my preview is not showing correctly, but after I save draft with the spaces between paragraphs, it simply is not there after I open it again…

    I have disabled my theme and all plugins to make this test without any bagagge. It does not work no matter what I do – it simply does not work.

    Any suggestions?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hello @misaka1,

    This issue is most likely caused by WordPress formatting the paragraphs automatically.

    Please install and activate the Code Snippets Plugin: https://wordpress.org/plugins/code-snippets/.

    Then add the following code to a new snippet:

    
    // Remove WordPress Autoformatting
    remove_filter( 'the_content', 'wpautop' );
    remove_filter( 'the_excerpt', 'wpautop' );
    

    That should allow you to format your posts and pages without WordPress changing the formatting.

    misaka1

    (@misaka1)

    Hey @nm1com,
    thank you for your suggestion! I have tried and it indeed works. The problem I have though is that I created all my previous posts with a plugin that forced the old classic editor over the WP one (Plugin’s name is Tiny Mce Advanced) and after applying the code the formatting got removed from all my previous posts.

    Can I somehow make this removal of autoformatting work only for the future posts that I am about to write and skip the previous ones that have already been created and are fine?

    Thank you!

    • This reply was modified 2 months ago by misaka1.
    • This reply was modified 2 months ago by misaka1.

    You’re welcome!

    In that case, you can use a plugin to enable or disable the autoformatting on the post edit page: https://wordpress.org/plugins/toggle-wpautop/. The plugin advertises that the autoformatting can be set to off for new posts, which is what you need.

    Or, you can try one of the solutions in the following article instead: https://blog.templatetoaster.com/wordpress-line-break-not-working/.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.