Support » Plugin: HAL » Imposible d’activer le plugin avec wordpress en 4.7.2

  • Bonjour,

    je souhaite installer le plugin HAL sur un site wordpress en version 4.7.2. Cependant, lors de l’activation, j’obtiens l’erreur suivante :

    L’extension n’a pas pu être activée, car elle a déclenché une erreur fatale.

    Parse error: syntax error, unexpected ‘[‘ in /net/www/html/wp-content/plugins/hal/wp-hal.php on line 144

    Auriez-vous s’il vous plaît une idée pour résoudre cette erreur ?

    Bien cordialement,

Viewing 8 replies - 1 through 8 (of 8 total)
  • Bonjour,

    Avez-vous une version PHP supérieur à 5.5 ?
    Car ce problème est connu des utilisateurs qui sont sur PHP 5.3.

    Bien cordialement,

    Thread Starter lelorax

    (@lelorax)

    Bonjour,

    Merci beaucoup pour votre réponse rapide… Effectivement, je suis bien en PHP 5.3.3 🙁 J’avis pourtant bien vu les prérequis 🙂

    Sachant que je ne vais pas pouvoir mettre à jour le PHP, existe-t-il un contournement autre que la mise à jour en PHP5.5 ?

    Bien cordialement,

    Je vais voir de mon côté si je peux modifier le code pour le rendre compatible en 5.3 car vous n’êtes pas le seul à me le demander.

    Bien cordialement,

    Thread Starter lelorax

    (@lelorax)

    Bonjour,

    Merci beaucoup pour votre réponse.
    Je me tiens à votre disposition pour tester si besoin.

    Bien cordialement,

    J’ai mis une version 2.0.5, si vous pouvez la tester et me dire si le problème figure toujours.
    Merci

    Thread Starter lelorax

    (@lelorax)

    Merci beaucoup.

    Je viens de tester. L’erreur est toujours la même mais plus pour la même ligne 🙂 :

    Parse error: syntax error, unexpected ‘[‘ in /net/www/html/wp-content/plugins/hal/wp-hal.php on line 774

    Thread Starter lelorax

    (@lelorax)

    Bonjour,

    Je vous prie de m’excuser de relancer cette discussion.
    Pensez-vous qu’une solution est envisageable pour résoudre cette dernière erreur ?

    Cordialement,

    Bonjour,

    La seule “bonne” solution est de passer à PHP 5.5, car si je réécris en PHP 5.3 le code ne sera pas du tout optimiser pour ceux qui sont en 5.5+.

    Cordialement,

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Imposible d’activer le plugin avec wordpress en 4.7.2’ is closed to new replies.