Support » Plugin: Podcast Importer SecondLine » Imports stopped working

  • Resolved Vasco203

    (@vasco203)


    Hello,

    I’m using your plugin for a while now. I’m so happy with it that I contributed to it with translating it to Dutch. But now since a few days the import stopped working.

    I cannot figure out why. In the site health I don’t see any WP cron issues and I already deactivated and activated the plugin again.
    I also entered the RSS feed url again but with no result.

    Hopefully you can help me with this.

    Thanks in advance,
    Vasco

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author SecondLineThemes

    (@secondlinethemes)

    Hi Vasco,

    Thanks for reaching out!
    I couldn’t reproduce the issue as it seems to be working on my side.

    When you go to “Tools -> Scheduled Actions -> Pending” and run the podcast importer task manually, do you see any change?

    Also, could you perhaps try to temporarily deactivate other plugins and test again?

    Thread Starter Vasco203

    (@vasco203)

    Hi thanks for the quick response.
    I uploaded another podcast to Anchor which successfully got imported.
    Strange enough the other one didn’t imported yet…

    In my hosting error log I found this:

    FastCGI: server "/var/run/php74-cgi/php-cgi" stderr: PHP message: PHP Warning: set_time_limit() has been disabled for security reasons in /www/wp-content/plugins/podcast-importer-secondline/app/Helper/Importer.php on line 181, referer: https://www.spotlight.fm/wp-admin/admin-ajax.php?action=as_async_request_queue_runner&nonce=0dfa1ac7ab

    I tried the manual import as you described, but it didn’t work.

    Thanks,

    Vasco

    Plugin Author SecondLineThemes

    (@secondlinethemes)

    Hi Vasco,

    I see – thanks for sharing the additional details.
    Please try to contact your WP hosting provider and check if they can enable the set_time_limit() function. Otherwise, you can also upgrade your PHP version to 8+ as it may help.

    If both won’t do it, you can comment out the set_time_limit() calls on lines 181 and 195 of the Importer.php file.

    Thread Starter Vasco203

    (@vasco203)

    Hello again,

    I upgraded to PHP 8.0 and 8.1 but both didn’t changed anything.
    Therefore I contacted my hosting company and they came with this answer:

    The message indicates that an attempt is being made to adjust this “set_time_limit” setting via your “podcast-importer-secondline” plugin on the indicated line.

    But you cannot adjust this value in our web hosting environment. This is a hardcoded setting that counts server wide, so also for all other users on this server.

    This is not something that has changed, but an attitude that has been established for years.

    My suspicion is therefore that whether this message has come up before, or that you are only seeing it now because the plugin needs longer than our set limit / or you have only recently tried to adjust this which is therefore not possible.

    I don’t know what the difference is between this attempt and the previous one, maybe you can make a comparison and test what works and what doesn’t.

    Hopefully you can help me any further?
    How can I update the plugin file without losing it while updating it in the future?

    Best regards,
    Vasco

    Perhaps the file is just too large for our 128MB limit, or the upload is not fast enough.`

    Plugin Author SecondLineThemes

    (@secondlinethemes)

    Hi Vasco,

    Thanks for the update.
    As mentioned earlier, you can comment out the function and it’d be a temporary solution. While you do that, could you please check with your hosting company what type of limit they’re using? I’d be happy to look into a more permanent solution.

    Thread Starter Vasco203

    (@vasco203)

    Hello,

    My web host is asking which setting you would like to know exactly so they can provide this.

    Thanks,
    Vasco

    Plugin Author SecondLineThemes

    (@secondlinethemes)

    I suppose we’re only talking about set_time_limit here right?
    If the value in the plugin exceeds the limit of your host – let us know what limit they use and we can try to find a solution around it.

    Thread Starter Vasco203

    (@vasco203)

    Hello,

    The set_time_limit is 128MB.

    Plugin Author SecondLineThemes

    (@secondlinethemes)

    Hi @vasco203,

    Hmm that doesn’t make a lot of sense – it should be a numeric value.
    Could you please double check with your host?

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.