Importing Problem (5 posts)

  1. mchlsync
    Posted 9 years ago #

    I'm getting this error when I tried to import xml which is exported from my blog to local wordpress.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 35 bytes) in C:\xampp\htdocs\wordpress\wp-admin\import\wordpress.php on line 87

    Any Idea how to solve this problem?
    Thanks in advance.

    Best Regards,
    Michael Sync

    P.S: XML file szie is 7.25 MB.

  2. amucklow
    Posted 9 years ago #

    Hi Michael

    I've read a few other strands on this, but none of them appears to solve the problem. I'm trying to import a blog from a Dreamhost Apache install to an Netcetera IIS install, and the import script triggers this error:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 24576 bytes) in \\nas1.hosting.netcetera.co.uk\inetc710$\virtualservers68647\hand-embroidery.co.uk\NewWebsite\wordpress\wp-admin\import\textpattern.php on line 621
    The Dreamhost php config allows a 90M memory limit, whereas the IIS config sets it at a measly 8M. I'm trying to get Netcetera to up the limit. In the meantime, I visited one site which advised adding
    at the start of the script (in my case textpattern.php) to increase the memory size for a single script. I upped it to 90M but still nothing.
    My XML file size is 40K.


  3. Chris_K
    Posted 9 years ago #

    Do you have access to php.ini file? That's where the 8MB php max mem value is defaulted.

    Might check with your host about boosting it.

  4. amucklow
    Posted 9 years ago #

    Thanks - I'm on to them. Evidently 8M is too small to run upgrade-schema.php as well.

  5. amucklow
    Posted 9 years ago #

    Just to follow up on this - Netcetera wouldn't increase the memory allocation on a shared hosting plan. I did eventually manage to export and import the blog in .sql format via phpMyAdmin.

    I was only able to run upgrade-schema.php after deactivating all plugins.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.