Support » Plugin: WP Photo Album Plus » Importing photos into an album

  • Resolved snakes_photos

    (@snakes_photos)


    I have problems adding photos into albums. The photos are on the server and are not zipped. When I set the source directory and select the photos, it says that they are imported but when I go to the album the thumbnails aren’t there. When I go to another area it says database fixed, invalid entries removed.

    I have 38 albums and this has only just started happening. 34 of them have imported without any issues but none of the remaining albums will import.

    If I delete the photo from the album it says that the file and the thumbnail do not exist.

    I have tried deleting the photos and uploading to the server again but this hasn’t made any difference. I have also tried deleting the plugin and re-installing from a fresh download. this hasn’t fixed it either.

    If anyone has any ideas it would be appreciated.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Are the original photos larger (in pixel sizes) than the coverphotos?

    Is your servers disk space not full?

    Set debug on ( put define('WP_DEBUG', true); in wp-config.php ). This may give you explaining errormessages

    The photos are the same size as an album that has already imported. They are 600 X 900 pixels and 240dpi.

    The server’s disk has plenty of space free.

    I have tried putting debug on but there aren’t any error messages.

    I have noticed that the files are moved to the wppa directory under uploads and the thumbnails are in the thumbnail directory under that.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    That is correct. Please make sure your filesystem accessrights are correct.

    CHMOD 755 should do it. You can change it using the Photo Albums->Settings admin page, table VII item 1. If that fails, use an FTP program to examine/set the proper rights on all the directories from wp-content down to thumbs.

    The rights are set correctly.

    I have found if I download the files from my server and upload them using the single file upload then I am able to add the files to the galleries.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Are the access rights on where they are originally on the server also correct? i.e. can you (try everybody) read them?

    Yes the rights haven’t changed.

    This is now working. I haven’t made any changes other than I have updated to the latest version.

    Thanks for your help.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    pls supply a link to your site, you may have had an issue that came up 2 days ago and is fixed in the mean time. I would like to verify that.

    afrogenius

    (@afrogenius)

    Hi there, I am relatively new to this plugin and have come across this same issue. I can import photos into my server no problem and also use the import into album option which works properly. However when I look in the album I don’t see the uploaded photos. I have gone through the solutions you suggested on this post but still does not work.

    i will now try an upgrade from 4.1.1 to 4.2

    afrogenius

    (@afrogenius)

    I have updated to v4.2.0 and still no fix to this issue. What am I doing wrong? Photos only upload if I do 1 @ a time.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    This is a known problem and will be fixed in the next version (4.2.1)
    In the mean time, explicitly select the album on the import screen (after Default album for import:) even when the right album is shown there. That should work

    afrogenius

    (@afrogenius)

    Hi there, thanks for your reply. Have tried your solution but still does not work. What to do next? When will the next version be release?

    afrogenius

    (@afrogenius)

    Not quite the solution I’m looking for but I’ve found I can select multiple photos for upload from the upload single photo option and upload all at once. Only setback is I have to select one @ a time.

    I can manage this for the mean time.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Should see update to 4.2.1 today.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Importing photos into an album’ is closed to new replies.