Support » Fixing WordPress » Importing old database

  • Long story short, I have a client who was managing his own website and it disappeared last July but he didn’t discover that until a couple of weeks ago. The hosting company doesn’t have a backup now of course, and the only backup he has is a database export done in 2013.
    I’ve tried importing it into a new WordPress site and it gets stuck at step 2. It asks Are you sure you want to do this? but it doesn’t give any button to select yes.
    Do I have any options here for how to do this?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hey!

    When you said you tried importing it, can you give me a little more info about the steps or technique you used?

    Thanks.

    Hi Kit,

    I just used the WordPress importer tool.

    Thanks. I just wanted to make sure we were on the same page. 😉

    Do you know what WP version that import was associated with?

    No clue, all I know is the file was exported in 2013.

    Let’s see if we can troubleshoot this thing together. Do you have any plugins installed and activated? If so, you may want to try deactivating them and trying the import again. In my experience, the imports can take what seems like forever, depending on how much stuff was included in the backup/export file.

    No, it’s a brand new WP install, no plugins installed yet, other than activating the importer.

    It lets me select the file and upload it, then gets stuck on the 2nd step where it asks if you are sure you want to do this. There is no button there to click yes, so all I can think of is that it’s a conflict between WP versions or database versions.

    That is what I was wondering too. (Great minds and all that stuff) Could your browser be blocking the button?

    I tried running the importer in another browser, with exactly the same result. Any other thoughts?

    The only things I can think of are:

    1. It’s just a bad/corrupt/partial export.
    2. The host has something locked down for “security.” (missing button)
    3. Database/software incompatibility. (Shouldn’t be this.)

    If the stinkin’ thing wasn’t 5 years old, I’d say to try another WP version BUT I don’t think that would help because you would have to try several. Plus, the host probably wouldn’t want you to do that because of the major security issues that could affect others, if this is on shared hosting.

    Any chance that he has another export file squirreled away in an old folder? I’m really wondering if this one is damaged.

    Just for your future reference, you may want to talk to hosting support to find out if they have any sort of restrictions to upload/install dates and if they have battened down the hatches too tight in this instance.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Importing old database’ is closed to new replies.