Support » Plugin: Featured Image from URL (FIFU) » Importing Image not automatically updated

  • 1) I install the plugin

    2) I import a post which includes a featured image. It WORKS…. but, for the image to display on the site (front-end) I have to go into each post from the back end – Edit, then save – I dont change anything. The post is updated when I edit and save.

    Is there a way to do this automatically?

    example – this upload works
    <wp:postmeta>
    <wp:meta_key><![CDATA[fifu_image_url]]></wp:meta_key>
    <wp:meta_value><![CDATA[https://www.egtest.com/images/cat.jpg]]></wp:meta_value>
    </wp:postmeta>

    Thanks for your help

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Marcel

    (@marceljm)

    Hi, @kristonr.

    1) Please access FIFU settings, Help, Support, data button. Click on that, copy and send me the data;
    2) How do you import your posts? Are you using some plugin for that?

    Hello.

    I’m experiencing the same issue. Please see data below.

    I’m using the default WordPress Importer plugin to export/import XMLs.

    Thanks.

    Featured Image from URL:3.0.0;
    WordPress:5.3.2;
    Site:https://360companysites.com;
    Theme:Twenty Seventeen;
    PHP:7.3.16-1+ubuntu16.04.1+deb.sury.org+1;
    WooCommerce:;
    Pages:5;
    Posts:0;
    Products:;
    Images without Dimensions:;
    URLs with Metadata:0;
    URLs:0;
    php-curl:yes;
    Plugins:
    – All-in-One WP Migration (all-in-one-wp-migration)
    – All-in-One WP Migration Multisite Extension (all-in-one-wp-migration-multisite-extension)
    – AutoChimp (autochimp)
    – Better Search Replace (better-search-replace)
    – Domain Mapping (domain-mapping)
    – Duo Two-Factor Authentication (duo-wordpress)
    – Elementor (elementor)
    – Featured Image from URL (featured-image-from-url)
    – Google Authenticator (google-authenticator)
    – Insert Headers and Footers (insert-headers-and-footers)
    – iThemes Security (better-wp-security)
    – PageSpeed Ninja (psn-pagespeed-ninja)
    – Query Monitor (query-monitor)
    – Relevanssi (relevanssi)
    – Safe Redirect Manager (safe-redirect-manager)
    – Search & Filter (searchandfilter)
    – SendGrid (sendgrid-email-delivery-simplified)
    – Smush Pro (wp-smushit)
    – Two Factor Authentication (two-factor-authentication)
    – WDS Active Plugin Data (wds-apd)
    – WordPress Importer (wordpress-importer)
    – WordPress Multisite Content Copier/Updater (wp-multisite-content-copier)
    – WPMU DEV Dashboard (wpmudev)
    – WPMU DEV Videos (wpmudev-videos)
    – WP Multisite Content Copier PRO (wp-multisite-content-copier-pro);
    Active Plugins:;
    fifu_auto_alt:toggleon;
    fifu_class:toggleoff;
    fifu_clean_dimensions_all:toggleoff;
    fifu_column_height:64;
    fifu_content:toggleoff;
    fifu_content_page:toggleoff;
    fifu_css:;
    fifu_data_clean:toggleoff;
    fifu_default_url:;
    fifu_dynamic_alt:toggleoff;
    fifu_enable_default_url:toggleoff;
    fifu_fake:toggleon;
    fifu_get_first:toggleoff;
    fifu_grid_category:toggleoff;
    fifu_hide_cpt:toggleoff;
    fifu_hide_page:toggleoff;
    fifu_hide_post:toggleoff;
    fifu_image_height_arch:;
    fifu_image_height_cart:;
    fifu_image_height_ctgr:;
    fifu_image_height_home:;
    fifu_image_height_page:;
    fifu_image_height_post:;
    fifu_image_height_prod:;
    fifu_image_height_shop:;
    fifu_image_width_arch:;
    fifu_image_width_cart:;
    fifu_image_width_ctgr:;
    fifu_image_width_home:;
    fifu_image_width_page:;
    fifu_image_width_post:;
    fifu_image_width_prod:;
    fifu_image_width_shop:;
    fifu_jquery:toggleoff;
    fifu_lazy:toggleoff;
    fifu_media_library:toggleoff;
    fifu_original:toggleoff;
    fifu_ovw_first:toggleoff;
    fifu_pop_first:toggleoff;
    fifu_query_strings:toggleoff;
    fifu_save_dimensions:toggleoff;
    fifu_save_dimensions_all:toggleoff;
    fifu_save_dimensions_redirect:toggleoff;
    fifu_social:toggleon;
    fifu_spinner_db:100;
    fifu_spinner_nth:1;
    fifu_wc_lbox:toggleon;
    fifu_wc_zoom:toggleon;
    Image:;
    Video:;
    Slider:;
    Shortcode:;
    REST Routes:
    https://360companysites.com/wp-json/:PHP;
    https://360companysites.com/wp-json/:JS

    Plugin Author Marcel

    (@marceljm)

    Hi, @rodrigoleon.

    To be honest, I didn’t know “WordPress Importer” until now. FIFU users prefer “WP All Import” plugin.

    I will check if FIFU and WordPress Importer can work together.

    Thanks @marceljm! I’d be happy to help. WordPress Importer is the default plugin WordPress tells you to download when you try to import (https://wordpress.org/plugins/wordpress-importer/). Thanks!

    Plugin Author Marcel

    (@marceljm)

    Yes, @rodrigoleon.

    I could see WordPress Importer has 40x more users than WP All Import. I’m surprised an integration was never asked before.

    Anyway, are you using that with fifu_image_url Custom Field, right?

    After an import, try to
    1) access Settings > Metadata
    2) enable Clean Metadata
    3) enable Image Metadata

    Let me know if that works.

    PS.: of course it’s not a definitive solution. It’s just to help you for now. I’m busy with some Premium issues this week, so I couldn’t check WordPress Importer yet.

    Thanks @marceljm

    This did not work for me sadly. I tried something similar before as well.

    Steps to replicate:

    1. Export post from site A.
    2. Import post to site B.
    3. Visiting post on site B shows no image.
    4. Visiting /edit.php on the dashboard shows URL image on column.
    5. Visiting post editor shows URL image, but the default feature image shows loading animation indefinitely.
    6. Update post without any changes.
    7. Visiting post on site B now shows image.

    As @kristonr said, one would have to visit and update each post to make this work. I have also tried visiting and updating permalinks to see if that would work.

    Thanks again!

    Plugin Author Marcel

    (@marceljm)

    Thanks for the information, @rodrigoleon.

    I will try to do an import now. Let’s see what happens.

    Plugin Author Marcel

    (@marceljm)

    Hi, @rodrigoleon.

    WordPress Import worked here. This is what I did:
    1) exported “All content”;
    2) deleted my posts;
    3) imported the file.

    And now I have the posts again with the external featured images working without additional steps.

    How are you creating your import file? Could you send me the file?

    Hi @marceljm

    I was actually importing based on a category. You can find my xml file here.

    There is only one file on the xml file.

    This is on a multisite installation with subdomains.

    Thanks!

    Plugin Author Marcel

    (@marceljm)

    Hi, @rodrigoleon.

    I imported the file, cleaned the metadata and enabled image metadata. And it worked!

    But let’s analyze the file now

            <wp:meta_key><![CDATA[_thumbnail_id]]></wp:meta_key>
            <wp:meta_value><![CDATA[8478]]></wp:meta_value>

    In my case, I didn’t have an image 8478 in my media library. Do you have it? If yes, it will be a problem because FIFU respects the internal images. Let me know.

    • This reply was modified 2 years, 9 months ago by Marcel.

    @marceljm

    Odd. I just tried it again with a different XML. I had the same issue, but doing the Metadata settings steps you recommended worked this time.

    I have a few images on the media library, but non of them are attached to any post via the default featured image section. I do notice that when I add a Featured Image from URL, when I refresh the page or revisit the editor, I see a feature image load on the default feature image section. I’m assuming this is related to the metadata.

    Plugin Author Marcel

    (@marceljm)

    but doing the Metadata settings steps you recommended worked this time
    Good. Use that for now, Rodrigo. I didn’t have time to check the integration.

    I have a few images on the media library, but non of them are attached to any post via the default featured image section.
    So why to import _thumbnail_id? I think your import file shouldn’t have this. Do you agree?

    I see a feature image load on the default feature image section. I’m assuming this is related to the metadata.
    Correct. FIFU cheats WordPress. Then the editor knows you have a featured image but it doesn’t know that it’s an external image.

    @marceljm

    Thanks will do that for now.

    I agree, but that is what the exporter gives me by default. Maybe it has something to do with how the plugin is tricking WP into using the image? So it thinks there is an image and sets _thumbnail_id?

    Plugin Author Marcel

    (@marceljm)

    Hi, @rodrigoleon.

    WordPress uses _thumbnail_id to link a post to its featured image. FIFU does exactly the same. The difference is that WordPress uses a real id of an image that exists in your media library while FIFU uses an id created by itself.

    When you clean FIFU metadata, _thumbnail_id is removed. And when you create FIFU metadata _thumbnail_id is inserted again (a new one).

    However _thumbnail_id is not the only field necessary to have a featured image. There are a lot of others. So, alone, it’s nothing (at least for FIFU).

    You could have all the other necessary fields exporting “All Content” and not only “Posts”, as I think you are doing. Then I think all would work fine, without an integration.

    I also believe that if you clean the metadata before exporting (Posts), you won’t have _thumbnail_id.

    Anyway, this week I will take a look at the Importer plugin. I hope FIFU can intercept the import and create the required metadata. It totally depends on how WordPress Importer was built.

    Plugin Author Marcel

    (@marceljm)

    @rodrigoleon,

    I did some more tests and the only way to remove _thumbnail_id from the export file seems to be cleaning FIFU metadata, what’s a bad thing. And since cleaning the metadata seems to be inevitable, I decided there will be no integration with WordPress Importer, but a troubleshooting that will be available in the next version:

    Showing the external featured images after an import:
    1) access Metadata tab;
    2) enable Clean Metadata;
    3) enable Image Metadata.

    Now I understand why the users prefer WP All Import. That makes the automation much easier.

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Importing Image not automatically updated’ is closed to new replies.