Support » Fixing WordPress » Importing iframes with the WordPress Importer

  • I was moving content from one WordPress installation to another one and encountered a problem.

    I had Youtube-movies embedded via iframe. These posts are exported correctly, at leaset the iframe exists in the .xml file.
    <content:encoded><![CDATA[<iframe src="http://www.youtube-nocookie.com/embed/HddnfmOzmcg?hd=1" frameborder="0" width="560" height="315"></iframe>]]></content:encoded>

    After importing the .xml file the iframe was gone. Not sure if this is a problem with the importer or the exporter, but I encountered this problem on two occasions with different installations (all were WordPress 3.2 though).

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi,

    It may be a problem with the importer. Try creating a sample blog in WordPress.com and importing your content there. If that works, export from that blog and import it once again in to your new blog.

    If this helps you, please let us know and mark this post as “Solved” to help others in the WordPress community to easily find the solution to this same problem.

    Cheers.

    So, I tried the suggested solution. The result wasn’t quite what I expected, I used the same content as before and the iframe got converted into an <a href""> link.

    The code from the xml I posted above looked like this in the wordpress.com-blog:

    <a href="http://www.youtube-nocookie.com/embed/HddnfmOzmcg?hd=1">http://www.youtube-nocookie.com/embed/HddnfmOzmcg?hd=1</a>

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Importing iframes with the WordPress Importer’ is closed to new replies.