Support » Plugin: Next Active Directory Integration » Importing Domain Users

  • Resolved odiggy


    When I put “Domain Users;id:513” in “Import members of security groups” like in your documentation, it splits it into two separate groups.

    Domain Users

    Thus I get 0 members in groups “Domain Users” and “id:513”

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter odiggy


    Never mind, I get a 0 members no matter what group I put. Also I don’t think you have to put “Domain Users”, you can just put “id:513”. I do have a connection to the domain controller. It just always says “no users found to sync.”

    [INFO ] Start of Sync to WordPress
    [INFO ] LDAP connection is *not* encrypted
    [DEBUG] Array
    [account_suffix] =>
    [base_dn] => dc=MNE,dc=local
    [domain_controllers] => Array
    [0] => dc08.mne.local
    [ad_port] => 389
    [use_tls] =>
    [network_timeout] => 5
    [ad_username] => admin@mne.local
    [ad_password] => *** protected password ***
    [DEBUG] Connection established with Domain Controller: dc08.mne.local
    [INFO ] In group 'id:513' are 0 members.
    [ERROR] No possible users for Sync to WordPress were found. 
    Plugin Contributor tobi823


    Hi odiggy,

    the behaviour is caused by the Active Directory.
    By setting “Import members of security groups” to “Domain User” the Active Directory returns only all “normal” members.
    By setting “Import members of security groups” to “id:513” the Active Directory returns all members which have as their Primary Group the security group “Domain User” with the id 513.

    You can verify that by:
    – open “Active Directory Users and Computers” on your Active Directory
    – open the properties window of an user by clicking him
    – select tab “Member Of”

    Please dont change the Primary Group of an user because of some side effects.

    • This reply was modified 5 years, 1 month ago by tobi823.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Importing Domain Users’ is closed to new replies.