WordPress.org

Support

Support » How-To and Troubleshooting » importing database

importing database

  • Hi i have a problem: i exported my wp database via phpmyadmin.
    Now i’m trying to clone my blog on a vmware based linux server soi can experiment without fear!
    Everything worked fine but the cloned blog doesn’t show the special characters correctly.
    Wp is set to utf-8 and I write a new post that displays correctly.
    Everything else worked fine except for this charset problem.
    Any clues any one?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator James Huff

    @macmanx

    Is the new blog using the same text encoding as the old blog? If not, it has to be.

    thx for answering, both blogs are set to utf-8 (in the options page) which i think is the default setting for wp. Anyway i checked it again but it was set as i remembered.
    Any other idea?

    I’m having a very similar problem. All the diacriticals on a server change installation got mangled on the import – checked the SQL dump file in Wordpad and even there it’s fine.

    I don’t recall changing the encoding default, but will try to spy a hint about it in Wordpad with the phpmyadmin backup file open.

    Also, a lot of these posts were pasted from emails which may have been of many encoding schemas. Is there a reason to assume that WP didn’t re-encode them on posting? They displayed fine in the prior install, and also in the SQL dump file as I mentioned – maybe they are all consistently now something other than UTF-8?!

    How does this work though. If WP is set to UTF-8, can’t it convert whatever other encoding might be specified on restored files?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘importing database’ is closed to new replies.
Skip to toolbar