Support » Fixing WordPress » Importing database from 2.7.1 install to 3.1.3 giving me errors

  • I’m trying to upgrade a client’s WP version as far up as I can (his hosting only has php 5.0.5, so we can’t get all the way to 3.2). Our starting point is 2.7.1. I tried to upgrade automatically (to 3.1.something, it was before 3.2 came out) and it was a mess of massive proportions. I began experimenting with upgrading in a separate folder on the server and am having the following syndrome occur.

    • I install 3.1.3 with no problem. Using Twentyten theme, I get Dashboard and site fine.
    • I install client’s theme – that works fine too.
    • I can’t use WordPress uploader plugin (I don’t know why – been over and over it), so I import database using phpMyAdmin. This doesn’t seem to work unless I clear the database I’m using for WP first, then import the old db into it.
    • I import the db from a.sql file, I go in and change some urls and the site looks okay.
    • When I try to go to the main Dashboard it gives me a message that the db needs updating. I say okay. WP says it’s been updated successfully.
    • I continue, and get the following message when I try to go to the Dashboard or the site:

    Fatal error: Only variables can be passed by reference in /netapp/whnas-silo1-node1/s8/s8/01296/www.mysite.com/webdocs/wordpress-313/wp-includes/rewrite.php on line 770

    This is, unsurprisingly, not what I want.

    Since this is a WP core file that’s throwing an error, I really don’t know what to do. Help?

    FYI:
    PHP Version 5.0.5
    MySQL – it says “5.1.51-log”

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator t-p

    (@t-p)

    Thanks, t-p, for the link. I’ve been following those instructions (forgot to mention) and have tried the incremental upload many many (many) times at this point. Just tried it again tonight – couldn’t even get from 2.7.1 to 2.9 without getting the error listed above as soon as the upgrade was done – normally I remember getting farther than that, but then I also don’t remember getting the database upgrade message at the 2.9 level previously. Weird.

    Again, to keep the existing site up while trying to work this out, I’m working on a separate folder on the server. This time, as a slightly different tack, I decided to make an exact copy of the live installation. I copied the entire folder, renamed it slightly and uploaded it back to the server. I deactivated the plugins by renaming the plugins folder to the very pithy “plugins-deactivated”. I created a new database (though Earthlink’s phpMyadmin system won’t let you copy a database directly into a new one, I created my own empty one and then imported the back up into it). I changed the config.php in the duplicate folder to connect to the duplicate database. I changed some urls in the database itself to correspond with the new folder address. It didn’t work at first, but then I reinstalled 2.7.1 and all was well. I then followed the directions from your link to upgrade to 2.9. Again, everything worked until the database upgrade.

    I really have no idea what to do at this point.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Importing database from 2.7.1 install to 3.1.3 giving me errors’ is closed to new replies.