Support » Plugin: WPGlobus - Multilingual Everything! » Importing content

  • Hi, thank you for creating my number one choice for localisation plugin!

    I recently run into an issue, where I need to import a lot of posts from another system. They are in two languages and I would like to import them as batch. I am using wpallimport pro for the task, but I cannot figure out how to do it. Do I need to add {en:}…{:} tags or does WPGlobus use a custom field or what do you suggest?

    Adding the tags is not an issue, just need to know the correct format.

    Thanks in advance 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Alex Gor


    WPGlobus supports language marks and stores strings in DB with them.
    So, if post title has ‘Title’ value for English, ‘Titel’ value for German
    then field ‘post_title’ in ‘wp_posts’ table has ‘{:en}Title{:}{:de}Titel{:}’ value.

    My languages are Finnish and English. I had the marks inserted correctly in my import file. However, they do not work correctly on the site. If I turn WPGlobus off for a post, I can see the marks are there, but when I turn WPGlobus back on, I can only see the Finnish translation in the Finnish tab (as it should be, of course), but the translation does not appear in the English-tab and neither is it visible when viewing the post on the public side.

    So importing kind of worked, but the translations do not seem to work at all. There must be some other piece of data needed? Perhaps WPGlobus does something when the post is saved or created that does not happen when importing it?

    Plugin Contributor Alex Gor


    Check that you have English as extra language
    on WPGlobus options page ( Languages tab )

    If by “extra language”, you mean that English is set as a language in WPGlobus settings, yes, this is the case. Translating content otherwise works fine, it’s just imprting tha does not 🙁

    Hi Alex, thanks for your continuing support 🙂 This is a rather important issue, since I would be sending the strings as excel files and combining them into a single string of content with language tags for importing. However, this is not working the way you suggest. Although the whole string, with language tags seems to be importing correctly, ehich I can see if I disable WPGlobius, it does not show up in the public side nor are the translations visible on the admin side, only the default language appears on both public site and admin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Importing content’ is closed to new replies.