WordPress.org

Forums

Imported WordPress.com XML file and nothing happened (8 posts)

  1. shani_b
    Member
    Posted 1 year ago #

    I've just switched over from WordPress.com to WordPress.org. I followed the directions for exporting the XML file, and followed the directions for importing the same. I used the WordPress importer. I checked Download & import file attachments.

    I see the media files are there, but none of the posts are appearing. What am I doing wrong?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    How large is your export file? Did you see any error messages when you tried to import it? Have you tried checking your site's error logs for messages. Your hosts should be able to help you accessing your site's error logs.

  3. shani_b
    Member
    Posted 1 year ago #

    It's 2.6MB. I've only had the blog since the end of August.

    I just checked the error log, and there are lots of "file does not exist." For example, "[Tue Dec 03 12:14:03 2013] [error] [client 8.31.236.255] File does not exist: /home/shedream/public_html/404.shtml, referer: http://shedreamsinperfectfrench.com/2013/11/26/giving-thanks-2/"

    I'm pretty much stumped.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    here are lots of "file does not exist."

    Don't worry about those errors. Sounds like your export file may simply be too large to upload in one go. You'd need to try breaking it down into much smaller chunks - each only 1 meg or less. Have a look at:
    http://www.gbmini.net/wp/2008/11/splitting_wordpress_export_import_file/
    http://www.rangerpretzel.com/content/view/20/1/

  5. shani_b
    Member
    Posted 1 year ago #

    Oh, thank you so much! I've been trying to do this at work, which is part of the problem. I'll have a look at this all later.

    I appreciate the help!

  6. shani_b
    Member
    Posted 1 year ago #

    Okay. Now I've split the file, even down to just .10 MB each, and it times out while the script is running, like in this post. What now? :)

  7. shani_b
    Member
    Posted 1 year ago #

    I have spent the last 3 days attempting to use this to import my XML file of my WordPress.com blog into WordPress. I followed all the directions. I split the file. I even split the file into sizes as small as .10 MB. It consistently times out while importing. My programmer brother spent all night attempting to do it. He changed the server timeout time. He split the file manually. It still times out. After it times out, media files are uploaded, but no posts appear.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you spoken to your hosts about this?

Topic Closed

This topic has been closed to new replies.

About this Topic