WordPress.org

Support

Support » How-To and Troubleshooting » Imported Database from old site – but cannot upoloda images!

Imported Database from old site – but cannot upoloda images!

  • Hi,

    First, I know what the cause of the problem is, but I don’t know how to resolve it.

    I had problems with a site so I finally backed up the DB, and deleted the account and etc in my cpanel – then I created a new account, installed WP, etc, and imported the DB.

    Unfortunately, when I created this new account I used a different username.

    When I try to upload images to a post – using the Media Uploader, it tells me:

    Add media files from your computer
    Unable to create directory /home/USERNAME1/public_html/wp-content/uploads/2008/10. Is its parent directory writable by the server?

    EDIT – hmm, same problem trying to upload plugins.

    Where USERNAME1 should now be USERNAME2 due to my new install.
    – How can I change this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • @phildub,

    An idea…

    Re-import user and usermeta tables from old into new DB.

    R

    Thank you – how do i do that please?

    @phildub,

    1) Open up the SQL backup in a text editor.
    2) Copy the code that recreates each of the above tables.
    3) Paste and run in phpMyAdmin (SQL) to recreate each table.

    Remember, this is just a thought and something I would try based on what you are telling us. I would naturally perform backups of DB along the way so thT i was easily able to rollback ‘just in case’.

    R

    Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Take a close look at the Settings->Miscellaneous page. Is your username on there anywhere?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Imported Database from old site – but cannot upoloda images!’ is closed to new replies.