Support » Plugin: FeedWordPress » Imported articles not found in some Queries

  • Resolved ngt4w0og

    (@moemorox)



    Hi there,

    I’m using FeedWordPress to import Articles from a site into a custom post type “articles”. This works very nice, thanks for that!
    Now I made a plugin, that gets new articles and sends them as mail.
    The query for this:

    $q = new WP_Query(array(
        'date_query' => array(
          'after' => $date,
        ),
        'post_type' => 'article',
        'nopaging' => true
      ));

    When executing the cronjob manually it works and sends all articles, when I’m not triggering it, it only finds the manually inserted articles.
    I have 3 different imported feeds and all of them are affected.
    I tried query_posts() before which had the same result.
    I also tried executing the cronjob serverside via crontab which didn’t change anything too.

    Does anyone have an idea where I can continue digging about this – I am at my wit’s end.

    Thanks in advance!

Viewing 1 replies (of 1 total)
  • OK, found the error..
    The feed has some kind of delay of 4 days so imported feeds get published in the past and my script couldn’t find it.
    dayum

Viewing 1 replies (of 1 total)
  • The topic ‘Imported articles not found in some Queries’ is closed to new replies.