Support » Plugin: WP GDPR Compliance » IMPORTANT: update to 1.4.3 immediately

Viewing 1 replies (of 1 total)
  • Plugin Author Donny Oexman

    (@donnyoexman)

    @artcolor; The found vulnerabilities have been patched. That said, you can never be absolutely sure if all of the code is completely safe. That would be great, but people keep on finding (new) ways to exploit pieces of code, unfortunately. That’s why software keeps getting updated regularly, to prevent these new (or old) exploits. And that’s what we will continue to do as well.

    @lobby13; It was possible to inject code into your site with the vulnerability found in older versions. This means that you need to scan your website for possible injected code, otherwise it doesn’t matter if you updated to a recent version as the injected code will still be there. If you need help with this I’d recommend contacting your server administrator (hosting) to go through it. If your website is still running/accessible it might also be helpful to scan your site with WordFence.

    @gomilky; Thanks for the “constructive” feedback. Wouldn’t it be great to have a bug-free (digital) world? Too bad we’re all human and we make mistakes. Even the biggest companies with billions of users still have/had exploits and even WordPress is still getting updated regularly to fix certain possible security issues. That’s (unfortunately) also part of the digital world.

    With hundreds of lines of code these kind of things can (and will) happen. It’s a bad thing however if we did nothing about it. Good thing we patched it within 24 hours. That said, we’re completely aware as to how to prevent these certain exploits. Thank you very much for the tip.

Viewing 1 replies (of 1 total)
  • The topic ‘IMPORTANT: update to 1.4.3 immediately’ is closed to new replies.