Support » Plugin: DeepL Pro API translation plugin » IMPORTANT : Troubleshooting

  • ResolvedPlugin Author Malaiac

    (@malaiac)


    A few messages have been posted here stating the plugin “doesn’t” work.
    It actually does (work). Tested today 2019/09/05 on the 1.1.7 version dated from 5 months ago on a new website, plugin downloaded from here (wp.org).

    What you need for the plugin to work is a DeepL Developer API key
    You can subscribe here : https://www.deepl.com/pro.html#developer
    It’s the 5 € monthly subscription (including 1 million characters)

    The plugin will not work without this API subscription.

    If the plugin still doesn’t work, please post here a message with details on your installation (ie, please mention your multilingual plugin if you’re using one).

    On a side note, I didn’t have time this summer to work on the full offer that is planned around this plugin. I am getting back on it. It will include :

    • one shot translation service to get a WP website (a.mysite.com) in language A translated in language B and ready to XML import into your new b.mysite.com
    • updates for this plugin
    • a new pro plugin to manage RSS feeds translation and batch translation
  • The topic ‘IMPORTANT : Troubleshooting’ is closed to new replies.