Support » Plugin: WP-ngrok » Important suggestion: code update.

  • I had a problem related to the URL being placed in CSS by Elementor. The plugin was not replacing the PATH for a relative PATH. The CSS was in the following format: “background-image:url(ABSOLUTE_PATH);”

    The solution was to add the following piece of codes after the row 131 from core.php:

    
    $page_html = str_replace('http://'.$_SERVER['HTTP_HOST'], '', $page_html);
    $page_html = str_replace('https://'.$_SERVER['HTTP_HOST'], '', $page_html);
    
    • This topic was modified 2 months, 3 weeks ago by darkfuria.
    • This topic was modified 2 months, 3 weeks ago by darkfuria.
    • This topic was modified 2 months, 3 weeks ago by Yui. Reason: formatting

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Thread Starter darkfuria

    (@darkfuria)

    What was done is not a 100% solution because there are cases where a URL contains another as a parameter, and in this case it can end up giving a problem. It is necessary to deal with regex. Some examples that may appear.

    
    ='http://meu-site.com.br'
    ="http://meu-site.com.br"
    :'http://meu-site.com.br'
    :"http://meu-site.com.br"
    url('http://meu-site.com.br')
    url("http://meu-site.com.br")
    ='https://meu-site.com.br'
    ="https://meu-site.com.br"
    :'https://meu-site.com.br'
    :"https://meu-site.com.br"
    url('https://meu-site.com.br')
    url("https://meu-site.com.br")
    
    • This reply was modified 2 months, 3 weeks ago by Yui.
    • This reply was modified 2 months, 3 weeks ago by Yui. Reason: formatting
    • This reply was modified 2 months, 3 weeks ago by Yui.
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.