Support » Plugin: Google Photos Gallery with Shortcodes » IMPORTANT: Google have turned down access to the Picasa API

  • ResolvedPlugin Author nakunakifi

    (@nakunakifi)


    Google have turned down access to the Picasa API, which is how the plugin retrieves photos.

    We have released v3.1.1 which will provide access to your images via the Google Photos API as of 15 March 2019.

    After 15 March 2019, the plugin can still function using the shortcodes that access the Google Photos API

    They are currently:

    * [cws_gpp_albums_gphotos access=own] to list Albums from Google Photos API, use option access=own or access=shared, to specify albums returned
    * [cws_gpp_images_in_album_gphotos] to list images in selected album
    * [cws_gpp_images_by_albumid_gp id='6625618881344302193'] to display images withing a specified album

    You will need to re-authenticate the plugin with Google to use the these new shortcodes.

    • This topic was modified 3 months ago by  nakunakifi.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Annie Adminisa

    (@annie-adminisa)

    The pro version should offer the possibility to view the images from 1 selected album. I cannot do this with the codes above. It shows all the albums and all the images, just like the free version.
    This doesn’t work as it should. Is there a changement after 15th of mars?
    Kind regards,

    Annie Adminisa

    (@annie-adminisa)

    Google Photos Plugin for WordPress -Google Photos Pro v3.0 WordPress Plugin

    The justified image gallery works!
    using the codes of the Google Photos Album ID finder
    Tested on one post:
    https://travelinpictures.be/2018/11/01/castelfranco/
    And this works!!
    Tomorrow i’ll trie all the other posts!
    Thanks, but i have to change all the codes. Fortunately, i can copy them all at once in excel. (Album name – Album ID) and use that list.
    Thanks.

    helmar74

    (@helmar74)

    Hi,

    I also had the “Sorry there has been a problem with your feed.” Error.
    I updated to Version 3.1.1 in wordpress and I “moved” over to the new api codes:
    Site 1 should show all albums:
    [cws_gpp_albums_gphotos access=own theme=grid results_page=bildergalerieneudetail show_title=1 show_details=1 num_results=10 hide_albums=’Auto Backup,Profile Photos,Automatische Sicherung,Diverse’ album_thumb_size=’200′]

    Site 2(bildergalerieneudetail) should show a selected album:
    [cws_gpp_images_in_album_gphotos theme=grid show_title=1 show_details=1 album_title=1]

    I get the following error:
    The Album titles are shown, but no album cover.
    If i click on a album, the album overview page (site 1) is openend again.

    The URL behind the empty album cover is :
    https://myurl/bildergalerieneu/?cws_album=&cws_album_title=
    … but it shouldn’t be bildergalerieneudetails?

    Maybe there’s an error in the plugin?
    I also reauthenticated my google account, this also was useless.

    I also figured out, that your demopage show the same error:
    http://wordpress-plugin-google-photos.cheshirewebsolutions.com/display-albums-grid-style1/

    Do I missed something?

    Thanks a lot

    helmar

    • This reply was modified 3 months ago by  helmar74.
    • This reply was modified 3 months ago by  helmar74.

    Hello,

    SOLVED! The codes down below are the right shortcodes.

    I have the same problem as Helmar74. my website is https://www.icgt.nl/fotos and when I click on a album it redirects to the same page and doesn’t show the photos on the selected album.

    Normally I would go from https://www.icgt.nl/fotos to https://www.icgt.nl/foto

    Please help, or am I doing something wrong?

    I use shortcodes:

    [cws_gpp_albums_gphotos access=own theme=’grid’ results_page=’foto’ show_title=1 show_details=0 hide_albums=’Auto Backup,Profile Photos’]

    to show the albums, and have shortcode:

    [cws_gpp_images_in_album_gphotos theme=grid show_title=0 show_details=0]

    on the other page to show photos of the selected album.

    Kind regards,

    Jens

    • This reply was modified 2 months, 3 weeks ago by  jenson94.
    • This reply was modified 2 months, 3 weeks ago by  jenson94.

    this plugin does not work anymore. it gives blank page using [cws_gpp_albums_gphotos access=own theme=’grid’ results_page=’foto’ show_title=1 show_details=0 hide_albums=’Auto Backup,Profile Photos’]

    I did set the API settings and authorised account but still blank using shortcode [cws_gpp_albums_gphotos access=own theme=’carousel’ results_page=’page-slug-here’]

    • This reply was modified 2 months, 1 week ago by  apinis.
    • This reply was modified 2 months, 1 week ago by  apinis.
    • This reply was modified 2 months, 1 week ago by  apinis.

    Sorry my mistake, everythinbg works fine.

    1. follow exactly this step by step https://www.cheshirewebsolutions.com/create-google-photos-api-credentials/
    2. authorise account (there were some bugs about this, had to disable enable plugin)
    3. use this on album page: [cws_gpp_albums_gphotos access=own theme=grid results_page=search show_title=1 show_details=0 hide_albums=’Auto Backup,Profile Photos’]
    4. use this on display page: [cws_gpp_images_in_album_gphotos theme=grid show_title=0 show_details=0]

    everything should work fine!

    p.s. at some point i had to refresh permalinks and on 2 different sites I could not use results_page=’foto’ and had to use results_page=foto because it messed up link and showed 404.

    Thanks for the plugin! Only thing maybe for future updates the grid layout is pretty ugly if some Album title name is longer than other.

    • This reply was modified 2 months, 1 week ago by  apinis.

    About the grid layout this did the trick

    div.thumbnail.grid-item.albums {
    height: 350px
    !important; }

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.