WordPress.org

Forums

Google Language Translator
Having flag display issues? READ THIS FIRST! (20 posts)

  1. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi everyone!

    It appears there a few users are experiencing some flag display issues after the update to 4.0.3. This is most likely due to their WordPress themes overriding the styles of the plugin.

    Here is what fixes that problem. Post this CSS into the "CSS Overrides" box in "Settings > Google Language Translator" in your WordPress Dashboard.

    #flags li {
        width:auto !important;
        float:left !important;
        padding:0 !important;
        border:none !important;
        list-style:none !important;
    }

    Please post a topic here if this fix below does not work.

    We will fix this annoying issue in the next update - sorry for the inconvenience.

    Rob Myrick

    https://wordpress.org/plugins/google-language-translator/

  2. ckhNL
    Member
    Posted 1 year ago #

    Thanks for posting this. I'm one of those users ;-)

  3. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ckhNL, thanks for posting. Hey if you like the plugin better now, would you consider revising your review.

    I'm planning on moving images to a sprite and also consolidating more code in the future as well.

    But no pressure... :)

  4. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    I also did fix the issue you were having with code loading in unnecessary places in your WordPress pages. All scripts are now conditional and load on the proper pages ( I believe )

    Thanks!

  5. martin.zsapka
    Member
    Posted 1 year ago #

    Hey!
    Unfortunately this code is not working for me. I pasted it into Settings/Google Language Translator -> Add CSS Styles. Did I do it right?

  6. martin.zsapka
    Member
    Posted 1 year ago #

    And the problem is that, the first flag is in a higher position, than the other ones.

  7. eddyther
    Member
    Posted 1 year ago #

    I also have a flag issue (even with your CSS adition)

    In the preview mode, the flags are ok, but in my site they are separated one from the other and between them there is a << sign

  8. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys, I'm sorry that you are having issues. Would either of you be willing to share a link to your website? I would need to see it in order to target the problem.

    You can send here if you want:

    http://www.wp-studio.net/contact/

  9. eddyther
    Member
    Posted 1 year ago #

    Hi.

    I sent it to the link.

    Thanks in advance

  10. fusionweb
    Member
    Posted 1 year ago #

    Hi,

    On this website we do not display flags. http://176.31.199.105/~lunallar/

    Thanks,

    Maite

  11. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    I can see you got it fixed - let me know if you need any futher assistance.

  12. frankie8
    Member
    Posted 1 year ago #

    Dear Rob,

    I have been trying to get the flags showing on my site now for 2 days - read a lot of the support queries and tried some solutions

    1. flash up to date
    2. added the CSS
    3. z-index:999
    I am using firebug and can see the flags div but it is greyed out. firebug shows the #flags css as display:none !important but with the site url and not the style.css url.
    If I delete the dsiplay none in firebug only one flag show up which is the original language flag.

    Please help!

    My url is francesnuttt.co.uk/FSSM

    thank you it will be a great plugin when working - the dropdown translate box works great already.

    I used the php code to put in my preheader

    Thank you in advance

  13. 1info6
    Member
    Posted 1 year ago #

    Hi, I have a problem - for each language are completely invisible flag. Entering the code did not work. In the administration lacks Flag Show Images "setting (" Yes, show flag images) as you write here: https://wordpress.org/support/topic/show-flags-in-header-of-website.
    Web site address is: http://www.buspress.cz/.
    Can you help me? Thanks.

  14. Edson Vaz
    Member
    Posted 1 year ago #

    Hello.
    I am facing the same problem, I can not do at all the aprecerem flags.
    It seems that the plugin is great, just need to solve this little bug.
    I'm starting to create my blog, I hope to have this beautiful plugin.

    http://descubrabeberibe.com.br/

    Thanks in advance

    Edson Vaz

  15. JohnMrC
    Member
    Posted 8 months ago #

    Flags are completely invisible for me too.

  16. evis
    Member
    Posted 8 months ago #

    Hi Rob,

    Thanks for the plugin, but unfortunately it did not worked for me under wp version 4.2.2.

    Are you willing to update to this version?

    Thanks

  17. alexandermp
    Member
    Posted 8 months ago #

    I have the same problem in the latest wp version..

  18. Ameet Agarwal
    Member
    Posted 7 months ago #

    I am using the latest versions of wordpress and the plugin.
    I can see the dropdown selection but cannot see the flags.
    http://www.sugarplumhotels.com/

  19. Ameet Agarwal
    Member
    Posted 7 months ago #

    Tried adding the css given at the top of the page but still no good.
    I can see the dropdown but not the flags :-(

  20. Ameet Agarwal
    Member
    Posted 6 months ago #

    Frustrated with no response.
    Finally junked this plugin and started using Google Translate. Its old and not updated for a while, but at least does the job for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Language Translator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic