Support » Plugin: CSV Importer & Exporter » Import won't recognize CSV file

  • Resolved jcharles


    I’ve saved my posts to a comma separateed CSV from Excel, but continue to get the following error message:

    Your CSV should contain “,” or “;” as delimiters.

    I opened the file in a text editor and confirmed that commas are correctly separating each value. As a doublecheck, I converted the file to CSV from Google Docs as well with the same result.

    Please advise. Thanks!

    – Jerry

Viewing 9 replies - 1 through 9 (of 9 total)
  • Okay, I’m pretty sure that this is actually an issue with Excel (and not the plugin) in that field data isn’t enclosed in required double quotes. This appears to be the case with Google Docs as well. I plan to test using Open Office which I heard preserves the double quotes. I’m guessing the plugin will then “see” the data.

    Plugin Author smackcoders


    Did that solved your issue. Let us know if you have any help further. Thanks for contacting.

    No unfortunately it still isn’t working. I saved the CSV with open office and it correctly added the double quotes around each of the comma separated values so that was good news. Here’s a copy from notepad that I created for test purposes:

    "post_title","post_content ","post_excerpt","post_type","_genesis_title","k12_pdf_url"
    "This is the test post title","This is the longer content","This is the shorter excerpt","k12_worksheets","This is the SEO title",""

    However, I continue to receive the same error. I even tried to save the character set as Western Europe ASCII/PC and then as Unicode UTF-8. No luck with either. I continue to get the following error:

    Note :-

    1. Your CSV should contain “,” or “;” as delimiters.

    2. In CSV, tags should be seperated by “,” to import mutiple tags and categories should be seperated by “|” to import multiple categories.

    Usually with these kinds of things it’s an error on my part 🙂 However, I’ve tried several things and am not sure what to do next.

    Any help is appreciated. I’ll continue to try to save in different character sets.

    – Jerry

    As a follow up I tried to save the file as a .txt file instead of .csv and still didn’t work. I also ensured that the proper permissions are set (777) and those settings are correct.

    I think problem is into upload_csv_file() function on control

    if ( count($headers)>1 && count($data_rows)>1 ){

    It should be

    if ( count($headers)>=1 && count($data_rows)>=1 ){

    In this way I can import my csv file



    Thanks for your help! That solved the problem. My test CSV record only had one row so it kept getting rejected. Since I’ll always be importing more than one row I left the code alone. My test with two records worked great.

    Thanks again,

    Plugin Author smackcoders


    Thanks marcoquattro and jcharles for your updates. I will note this and update the code as to support even for single row in next release.


    I am having the same problem and my CSV have 3 columns.

    I have deinstalled and reinstalled your plugin.

    Now even the files which it had loaded erlier, it can’t work with them.



    Forum Moderator

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Import won't recognize CSV file’ is closed to new replies.