Support » Fixing WordPress » Import RSS doing nothing

  • I haven’t posted here before because I can normally find the solutions I need through searching. This time, however, I can only find other posts that describe my problem, but no replies or solutions.

    I’m attempting to import posts from a non-Wordpress blog. It’s not one of the listed choices, so I’m attempting to use the “Import RSS” method. Each time, I progress through the process, reach the “All done, have fun” page, but no posts have been added. Checking the files at my web host, it also appears that nothing has been uploaded.

    Does anyone have any ideas as to the cause of this problem (the file is not too large) or any other method of importing old non-WP posts? All help will be greatly appreciated!!


Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello, any progress with this by any chance? I’m fighting with this myself, although I’m getting an error to the tune of

    Couldn't get post ID

    I do know that it does not like the date formatting from my rss.xml file, and furthermore I’m getting a php error in my logs, whereas it sounds like your file upload mechanism may not be working, but if there’s anything we could do to help each other, I’d be game!


    I’m having the same problem. My blog was run on Expression Engine. I loaded the RSS feed, viewed the source and saved it as a text file, as per instructions I’ve seen in several places.

    I’ve tried several times to use the import tool from the dashboard, and it always says “All Done, Have Fun” but nothing is added. I have archives dating back to 2002 that I’d really like to keep. Anyone??

    I have the same problem while trying to import a bunch of Delicious links with comments. WordPress says:

    Are you sure you want to do this?
    Please try again.

    And there is NO button or link to confirm my wish…

    I got it to work. I had both a .txt version and a .php (webpage) version of my RSS archive feed saved on my hard drive. In the WP dashboard where you can import, I chose Movable Type and Typepad, chose my .php file, and it worked. Saw that on another forum somewhere so I thought I’d give it a try. Why no one on here will tell you about this workaround, I have no clue, but I just wasted a week trying to figure it out!

    I only have an XML version of my RSS feed which I have got from copy and paste from the website. Why doesn’t the rss import feed work?

    I will be moving a EE account to an existing WP account, so I began looking for a smooth way to do this. Hoping WP would already have a slick little plugin for it, I came here, but found the state of confusion I didn’t want to find. So, I Googled and found the answer. It’s not totally ‘neat’, but it’s a very powerful and working solution. owner wrote a patch to do the work. Not sure how elegant it is, but it does appear to do the job. Here’s the link to the download of the code.

    As to a list of Instructions for doing this… well, I’m not exactly sure. The links above speak of “How To” only briefly. It may be more intuitive that it currently seems. I WILL find out.

    I hope this has helped.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Import RSS doing nothing’ is closed to new replies.