Support » How-To and Troubleshooting » import problem – page already exists

import problem – page already exists

  • Hi all,

    WordPress is saying that “pages already exist” when I import xml but they don’t exist!

    I’m working with two WP websites. One is a development site and the other is the live main site. I exported all content from the development site to an xml file. I then deleted ALL posts, pages, and media from the main site. I try to import on the main site using Tools>Import>WordPress and select the xml file.

    When I import it says that “page already exists” for all my pages. The pages used to exist on the main site, but now they don’t because I deleted them before I tried to import. I know it is standard wordpress procedure to not import existing pages, but how come I can’t import pages that used to exist???

    Is this a bug in the delete mechanism?


Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having the same problem. Any suggestions?

    When you say you deleted them, did you also empty the trash, thus deleting them permanently?

    I’ve not used xml import, but it could be possible that the importer sees the deleted posts if they are still inside of the trash.

    I tried

    1. deleting all of my themes from both my finder and from wordpress
    2. emptying the trash
    3. reinstalling
    4. Then when I import my xml file I get a big list of files that “already exists”

    Media “home-image” already exists…

    did anyone find a fix for this I’m having the same problem?
    Media “<filename>” already exists…

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘import problem – page already exists’ is closed to new replies.