Support » Plugins and Hacks » Import Not working with CSV file

Import Not working with CSV file

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi John,

    How’s things? Hope you’re well. 🙂

    I have the same issue as dsaro – uploading the CSV file leads to a blank page. I’m using WP3.9.2 and the latest version of the plugin (v2.3.6).

    Also, I just noticed on the documentation that there’s no real notes on how to use the upload feature, or what the CSV file should contain. I thought there used to be a sample CSV file… not sure.

    Anyway, hope this is fixed soon.



    I created 3 redirects, exported and saved the csv file, deleted the redirects in WordPress, tried to import the saved csv file and it doesn’t work.

    When you get a blank page, are you still getting the WordPress screen but with no content in the middle? Or are you getting a plain white screen with nothing on?

    If the answer is the first one, try the solution here, it worked for me:

    ZainB, to find out how the CSV should be formatted, add a couple of redirects manually then export them to CSV. Use this as a template for your upload.

    The only thing that works for me is to install a previous version like 2.3.5 (http://downloads.wordpress.org/plugin/redirection.2.3.5.zip) , import your CSV (it should work in this version) and then after everything’s imported, upgrade to 2.3.6.

    But beware, if you need to import again, you’ll need to downgrade back and do the same thing over. So you might just want to stay at version 2.3.5 if you know you are going to be importing again (until this is fixed).

    It’s pretty lame but it’s the only way I can get it working. Also, the Redirection logs settings are different in versions 2.3.5 and 2.3.6 , so don’t forget to check those if you don’t want the logs to be stored.

    I used @samantha Miller’s solution and it worked perfectly. I wasn’t getting an error, just a blank screen. I made the changes in the post she referenced, then it still didn’t work.

    I found another post saying the CSV file has to be Windows Comma Separated. I made that change and it imported perfectly.

    My file is A1-A58, old URL and B1-B58, new URL. No header row.

    Thanks to everyone for posting solutions!

    Thanks @darkhouse20! the 2.3.5 version downgrade worked perfect.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Import Not working with CSV file’ is closed to new replies.