• Resolved joeytroy


    Firstly I am using WordPress 6.1.1 and Participants Database 2.4.5.

    The issue I am having is I created a handful of custom Participant Info Fields for the Manage Database fields. I made sure to check Signup, CSV, and Sortable on all the entries and also made them required.

    Issue #1
    When I go to Import CSV and download the Get Blank CSV File it’s missing all my custom fields even though it shows the full list of 15 options on the page. When I download the CSV I only get “first_name,last_name,email,address,city,state,zip”

    Issue #2
    Even though my CSV includes all 15 fields exactly how the “name” field is listed in the Participant Info Fields, it does not import anything into the 8 extra fields I added even though there is data.

    Any assistance would be appreciated. This is an amazing little plugin and it would be very helpful for our non-profit group! If we can get it working we will also purchase the Combo Multisearch as well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter joeytroy


    As a temporary fix I imported all the data from SQL and it’s working but this probably need to be looked at.

    Plugin Author xnau webdesign


    It sounds like you did everything correct, so it should be working, I just tested it, so I know that is it not broken in general.

    The “blank CSV file” is just to get you started, it only includes the fields that are configured for export. This is configured on the Manage Database Fields page, each field has a “CSV” checkbox that enables the field for export.

    On import, you can include any valid fields (the export setting doesn’t matter), so you are right to expect those to import the data in the CSV.

    I can’t address your issue specifically, I don’t know what you have in your CSV, or what kind of data you tried to import, what confirmation messages were shown, or even what you did to verify if it worked or not.

    I would suggest you look closely at the configuration settings on the CSV import page to make sure the import is doing what you want it to do…for example, if you want to update existing records, you need to make sure the CSV has a record ID or other information that can be used to identify which record to update. The confirmation messages can help explain what happened.

    Using a direct import to the database can work, but you can run into trouble with field types that expect something specific in the import. The plugin’s import takes care of that for you.

    Thread Starter joeytroy


    xnau webdesign,

    I got it solved, I must have messed something up. I deleted all the tables in SQL and uninstalled and reinstalled the plugin and it’s all working properly now!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Import Not Working’ is closed to new replies.