WordPress.org

Support

Support » How-To and Troubleshooting » Import MT3.2 into WordPress 2.0.2

Import MT3.2 into WordPress 2.0.2

  • Hi Folks,

    I’ve used wordpress in the past but with version 2.0.2 i’ve got a little stuck on importing MT 3.2 into wordpress 2.0.2.

    I have gone into MT and have exported all of my post into a single text file to my local PC, then I have logged into WordPress and have gone into the import section, then selected the MT import option, then browsed to the MT export and told it to import but nothing imports eventhough WordPress says that the import has worked.

    Can anyone sugguest some things I can try to fix this?

Viewing 15 replies - 1 through 15 (of 19 total)
  • *shameless bump*

    another *shameless bump*
    i really could do with some help

    What database (name and version) are you using? Have you looked into it to verify if data was imported?

    Hi dneto

    I’m using mysql 5 on windows iis webserver.
    Yes I have checked to see if the data actually imports and nothing gets imported, no posts, no comments, nothing.

    I used to use wordpress when it was version 1.x so its not as if i’ve never done an import before.

    Is your MySQL running other databases or just the wordpress? I mean: is this a fresh installation? If yes, check the permissions to add entries on it, okay? I’ll be here waiting your feedback.

    Hi dneto

    I don’t mean to sound ungrateful but I know how to setup mysql & how to configure user access I work in an IT department & I’m a SQL database administrator.

    I have many databases in my mysql installation, I know the wordpress database is fine as I can import data using the “Import posts from an RSS feed” and that does work but only import the current week’s posts which are no good to me.

    I have queried the database and no data gets written to the tables, I’m supprised its not working since in previous versions you have to set the import directory then place the file into that folder and this version gives you the option to browse to the import file so there is no configuring to do.

    As a test I exported one entry which was a simply one liner saying “hello” but even that failed to import.

    I can provide anyone with a sample of the data I am trying to import if they want to have a go at import it into their own database to see if it works, there might be some issue between MT 3.2 and the wordpress importer. Also if anyone wants to send me a simple entry to import I will try to import that, at present I can not say if its MT’s export or if its wordpress that is not functioning correctly.

    Puerilis,

    No problem, man.

    Well, this seems very odd. Here I’m using linux to the database and webserver (mysql and apache) and I cannot tell you if the importer is doing fine for the Windows environment. Can you send a simple post (in MT format, of course) for me to try here?

    Hi dneto,

    download http://www.jamestk.dsl.pipex.com/sample.zip
    its a one line sample file with just one MT entry.

    I’m pretty sure it is windows or php not handling the request correctly, i’ve even allowed php to use more memory by changing the line in the php.ini that sets the max memory to 100 MB.

    hey dneto, any luck with testing the import?

    Puerilis,

    I saw your extract and it differs from mine for just one thing: the end of line character. I think the WP importer tries to find this and your MT exported data doesn’t contain it. I dunno if your MT does the export correctly, but I can see it doesn’t have this character. Here’s an extract of mine:

    http://www.danielneto.com.br/weblog/extract.zip

    Open it using your favourite uncompressor program and see the text file inside it with notepad and compare with yours. Gimme your feedback and good luck!

    Dneto

    You didn’t say what version om MT you are using but i’m using MT 3.2 and in 3.2 you click on the “Export Entries” tab and it gives you a link which when you click on it, it asks you to save the file to your pc.

    I just tried you import your file and it said “import done” but nothing imported, the wp_posts table is still 0 rows

    Same upgrade MT 3.2 into wordpress 2.0.2 problem (The uploaded file could not be moved to .) Docs are not updated to reflect changes in uploading to contents directory. Is nobody upgrading or is the answer hiding somewhere in the forums and I can’t find it?

    Hi relaxedguy

    Is you server a window or linux server ? could be good old winblows (windows) messing again

    Puerilis,

    I was using MT 3.2 also. The exported data was correctly imported into the WP 2.0.2, but I think your Windows server is messing somewhere else in your proccess. I really dunno what’s going on there, ’cause here I’m using Linux… BTW, I wrote an Apache configuration that forbids external links to my ZIP/RAR and image files. Here’s another link that’ll permit you to download it:

    http://www.danielneto.com.br/weblog/extract.tar.gz

    Hi dneto

    I did download the first zip file you posted the link to but I can’t now so I guess you made that change to you apache config after I had for the file.

    Anyway, regardless of what file I try to import the wordpress system does not import any data when using the MT import function.

    I’m quite supprised that WordPress have not updated their documentation as when you search their documents for “how to import” all of the results point to the old documentation.

    To be honest, I don’t think I am going to waste any more time in this, I have a fully working MT 3.2 system that can perform functions that wordpress can not (for example multiple users without having to use plugin’s).

    I was only trying wordpress to see what had changed from version 1.5.

    I wish you all the best with it.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Import MT3.2 into WordPress 2.0.2’ is closed to new replies.
Skip to toolbar