Support » Plugin: Zotpress » Import Library never completes

  • Resolved mark.clarke@trainsmart.com

    (@markclarketrainsmartcom)


    Hope someone can help me …

    new user to Zotpress. Love the idea and hoped this would be the answer to my referencing needs. Set up my a/c on the Zotero website and input my API/key into the WordPress fields. I have only 2 references in my library yet WordPress is unable to import the library for me to start referencing my blogs. I click “import” and it has the “working” animation bar running and never finishes.

    I’ve checked the forum but can’t seem to find any answers. Can anyone help please?

    Regards
    Mark

    http://wordpress.org/extend/plugins/zotpress/

Viewing 15 replies - 1 through 15 (of 38 total)
  • I am having the same problem. I am also a new Zotpress user. I think we are using 3.5.1 wordpress and 5.0.6 Zotpress. I have tried connecting to a variety of groups and personal libraries and nothing ever imports. It sounds like a similar problem to http://wordpress.org/support/topic/version503-cannot-import-any-items-in-wordpress-35 but with newer versions.

    Thanks for your help
    Wendy

    Plugin Author Katie

    (@kseaborn)

    Feel free to contact me for debugging. http://katieseaborn.com/contact

    Did you all every resolve your import issues? I’m having the same problem. Import never finishes on my test library with 2 items in it. I have a LOT of security features enabled for WP, including a firewall, and HTTPS. Any chance these could be interfering?

    Well, I did the sensible thing and disabled most of my security. Now the import is chugging along 🙂

    Plugin Author Katie

    (@kseaborn)

    I’m in the process of re-coding for compatibility. Sorry about the troubles. Stay tuned!

    Hi Winslow,

    Glad you managed to fix it. Katie was brilliant and helped us get it working. We had to change a line of code in the PHP. Our developer also suggested a change which removes the need for any external libraries. I think Katie is looking at this and making an upgrade.

    Hope you managed to get it working.

    Regards
    Mark

    I am also new to Zotpress. I have a group library I want to import. I started the import. It never ends and it looks like nothing is imported.

    I wonder if I have the correct ID for the group. I click on “Group Settings” here:

    https://www.zotero.org/groups/from_some_psychologists

    (The link “Group Settings” is only shown when I am logged in.)

    The URL is of the form https://www.zotero.org/groups/ID/settings where ID is the number I then enter into Zotpress.

    Is “ID” above the number I should use?

    Plugin Author Katie

    (@kseaborn)

    Thanks to Mark’s developer I’ve now implemented a WP-based (and hopefully more compatible) way of importing. I think this should settle the issues everyone’s been encountering, but if not, please re-open this thread.

    Hi Katie, I just updated the Zotpress-plugin and tried again. It looks like it still does not import anything.

    Hi,

    I just downloaded Zotpress but unfortunately it doesn’t work for me either — the import completes, but nothing shows up in my library.

    Best,
    Nidhi

    I am having the same problem. I thought it was because of the size of my library — but I see now that others have this issue. What can we do?

    Actually my mistake was not making my library public. Once I did that, it worked like a charm.

    @nidhi.r.kalra: Since it is a public library maybe you could give me the URL so I can test importing that library instead of my own (that does not work)? 😉

    Try this: 1348997

    In Zotero, go into settings->privacy and check “publish entire library”

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘Import Library never completes’ is closed to new replies.