Support » Plugin: Import External Images » "Import Images Now" and nothing happens

Viewing 7 replies - 1 through 7 (of 7 total)
  • I get the same result.
    Any solutions?

    I found a solution.
    On the line in import-external-images.php

    posts = get_posts( array( 'numberposts' => -1 )

    I changed it to
    posts = get_posts( array( 'numberposts' => 500 )

    No Idea what that does, but it works

    Tried this but it still doesn’t work for me.
    All of the posts come back with “No images imported – you might want to check whether they still exist!”

    @dwheeler – Thanks so much, your solution worked perfectly for me! But for those needing specifics, near line 321, replace:

    $posts = get_posts( array( ‘numberposts’=>-1 ) );

    with this:

    //$posts = get_posts( array( ‘numberposts’=>-1 ) );
    $posts = get_posts( array( ‘numberposts’=>500 ) );

    Well forget that! The solution above only worked once. No matter how many times I try, it will not import images from any further changes. Bummer!

    Another option you can try is to create a php.ini file with increase memory and timeout limits.

    Take your server php.ini file save it into wp-admin, then make any memory or time out changes. The ini setting should only effect what happens in the wp-admin area.
    My WordPress has 90k posts with 3 or for images per post and 120+ posts added each day.

    If you getting No Images imported, that is a different issue. What ever import engine you are using should import the images automatically. I use wpallimport. It takes some configuration but once it is working it is flawless.

    Thanks, dwheeler’s solution worked for me as well. numberofposts is an older version of the posts_per_page parameter to get_posts… “-1” means to get all. This can timeout on sites with large #’s of posts.

    A potential way to fix this would be to get a count of all posts, then run get_posts with a smaller posts_per_page value and an offset, so you are getting 1-50, then 51-100, etc rather than trying to load all posts into memory.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘"Import Images Now" and nothing happens’ is closed to new replies.