Support » Plugin: Yoast SEO » Import from AISEO made all posts noindex!

  • Resolved ripperj7

    (@ripperj7)


    So this week, i switched from AIOSEO to Yoast. This morning, I decided to import my metadata from AIOSEO. Now, all of my posts have the blue “noindex” dot next to them. I have tried undoing this, and I cannot. I have to go into each blog post and do it manually. I have just under 1000 blog posts. Can anyone assist?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support devnihil

    (@devnihil)

    @ripperj7 We’re sorry to hear that you are experiencing this issue after importing your metadata. We tried checking on your site http://theoccultsection.com/ however we received a 503 error when we tried visiting it (see image here).

    As for the posts being set to noindex, we would recommend checking to make sure the robots meta tag is NOT set to noindex for the post in Yoast SEO, and you can check this setting by performing the following actions:

      • Go to the Edit screen for a post
      • Scroll down to the Yoast metabox
      • Click on the ‘Advanced’ area
      • For ‘Allow search engines to show this Page in search results?’ make sure this is set to ‘Yes’
      * Note (setting this value to Yes will set meta robots to index and setting No would set meta robots to noindex)

    In addition, you can set posts to be indexed by performing the following actions:

      • In WordPress go to SEO>Search Appearance>Content Types
      • For Posts set ‘Show Posts in search results’ to ‘Yes’
      • Click ‘Save Changes’

    ​Can you please try the aforementioned suggestions and let us know whether this resolves your issue?

    We also have a guide on how to set a page/post’s meta robots tag to noindex here: https://yoast.com/help/how-do-i-noindex-urls/

    • This reply was modified 3 months, 3 weeks ago by devnihil.
    Thread Starter ripperj7

    (@ripperj7)

    Thank you. I performed both of your suggested actions earlier, and it didn’t seem to work. Every post was still showing the blue dot and saying it was set to “noindex.”

    My site is inaccessible right now because I am restoring a backup from before I imported from AIOSEO. I will let you know once the backup is complete if it has fixed my issue. Thanks again!

    Plugin Support devnihil

    (@devnihil)

    @ripperj7 Thanks for your reply. Please do let us know once you’ve completed your backup restore if the issue is corrected.

    Thread Starter ripperj7

    (@ripperj7)

    Ok so my hosting company was able to restore my backup. Sadly, my site of almost 1,000 blog posts was noindex-ed, and while everything is back to normal now, I’m waiting for everything to be crawled by Google again. Thank you for your help. Not sure why, but AIOSEO apparently changed my robots.txt file to disallow my sitemaps, which started the issue. AIOSEO wouldn’t allow me to edit the robots.txt file. When I switched to Yoast, my metadata was gone, and when I imported the AIOSEO data, it for some reason changed every single post and page to “noindex.” Frustrating!

    Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    We checked on your latest post https://theoccultsection.com/2021/01/07/on-the-trail-of-hauntings-review/ and we do see that in the page source, the meta robots tag is now set to ‘index’ so that should signify to the search engines that you want this post to be displayed in the search results.

    If you switched from another SEO plugin to Yoast SEO, you might be using Yoast SEO’s sitemap index which can be found at https://www.yourwebsite.com/sitemap_index.xml. If this is the case, we recommend you remove any outdated sitemaps and submit the Yoast sitemap — https://yoast.com/help/submit-sitemap-search-engines/

    Thread Starter ripperj7

    (@ripperj7)

    Thanks. I’ve resubmitted my sitemap, using the new Yoast one, and am waiting for my site to be reindexed.

    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Great, hopefully, the issue will be resolved once Google recrawls the entire website for you which may take a little while.

    Let us know if we can be of any further assistance; we’re happy to help!

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.